zoukankan      html  css  js  c++  java
  • POJ 2586:Y2K Accounting Bug

    Y2K Accounting Bug
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 11297   Accepted: 5686

    Description

    Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
    All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

    Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

    Input

    Input is a sequence of lines, each containing two positive integers s and d.

    Output

    For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

    Sample Input

    59 237
    375 743
    200000 849694
    2500000 8000000
    

    Sample Output

    116
    28
    300612
    Deficit

    题意是这个公司只有5个月的财务报表,因为一年有12个月,所以这样的财务报表有8个,这8个财务报表都是亏损,这个公司自己也不记得哪个月盈余哪个月亏损,只给出盈余多少,亏损多少。求该公司一年的最好盈余情况,如果不可能盈余,就输出Deficit。

    我自己是不知道为什么这道题被归到了贪心里面,就是四种情况取最大值呗。

    SSSSDSSSSDSS

    SSSDDSSSDDSS

    SSDDDSSDDDSS

    SDDDDSDDDDSD

    之前反倒吃了贪心的亏,忘记了要输出最好情况结果还来了两个WA。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    using namespace std;
    
    int main()
    {
    	int s,d;
    	while(cin>>s>>d)
    	{
    		int result=-1;
    		if(4*s<d)
    		{
    			if(10*s-2*d>result)
    				result=10*s-2*d;
    		}
    		if(3*s<2*d)
    		{
    			if(8*s-4*d>result)
    				result=8*s-4*d;
    		}
    		if(2*s<3*d)
    		{
    			if(6*s-6*d>=0)
    				result= 6*s-6*d;
    		}
    		if(s<4*d)
    		{
    			if(3*s-9*d>result)
    				result=3*s-9*d;
    		}
    		if(result<0)
    		{
    			cout<<"Deficit"<<endl;
    		}
    		else
    		{
    			cout<<result<<endl;
    		}
    	}
    	return 0;
    }


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    PostThreadMessage
    WaitForSingleObject函数的使用
    CodeWarrior环境下中断使用
    Activity跳转时生命周期跟踪
    win7 VS2012+openCV-2.4.11 配置
    CodeBlocks16.01+wxWidgets3.0.2
    MFC一个类访问另一个类成员对象的成员变量值
    无法打开包括文件:'atlrx.h'的解决办法
    STM32f103的数电采集电路的TIMER定时器的使用与时序控制的程序
    STM32f103的数电采集电路的双ADC的设计与使用
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785854.html
Copyright © 2011-2022 走看看