zoukankan      html  css  js  c++  java
  • POJ 1459:Power Network 能源网络

    Power Network
    Time Limit: 2000MS   Memory Limit: 32768K
    Total Submissions: 25414   Accepted: 13247

    Description

    A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount 0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

    An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)%3��J�ub>max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

    Input

    There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

    Output

    For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

    Sample Input

    2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
    7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
             (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
             (0)5 (1)2 (3)2 (4)1 (5)4

    Sample Output

    15
    6

    Hint

    The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

    在能源网络中,有一些是发电站,有一些是转发站,有一些是消耗站。给了网络中边的容量,以及哪些是发电站,能发出多少电。哪些是消耗站,消耗多少站。问在能源网络中,最大流是多少。

    建立一个超级源点,将超级源点与各个发电站相连,边得容量是发电站发的电。

    建立一个超级汇点,将超级汇点与各个消耗站相连,边的容量是消耗站小号的电。

    求添加了这两个点之后的网络流的最大值。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <queue>
    #include <cstring>
    #pragma warning(disable:4996)
    using namespace std;
    
    const int sum = 200;
    const int INF = 99999999;  
    int cap[sum][sum],flow[sum][sum],a[sum],p[sum];
    
    int n,np,nc,m;
    
    void Edmonds_Karp()  
    {
    	int u,t,result=0;
    	queue <int> s;
    	while(s.size())s.pop();
    
    	while(1)
    	{
    		memset(a,0,sizeof(a));
    		memset(p,0,sizeof(p));
    
    		a[0]=INF;
    		s.push(0);
    
    		while(s.size())
    		{
    			u=s.front();
    			s.pop();
    
    			for(t=0;t<=n+1;t++)
    			{
    				if(!a[t]&&flow[u][t]<cap[u][t])
    				{
    					s.push(t);
    					p[t]=u;
    					a[t]=min(a[u],cap[u][t]-flow[u][t]);//要和之前的那个点,逐一比较,到M时就是整个路径的最小残量
    				}
    			}
    		}
    		if(a[n+1]==0)
    			break;
    		result += a[n+1];
    
    		for(u=n+1;u!=0;u=p[u])
    		{
    			flow[p[u]][u] += a[n+1];
    			flow[u][p[u]] -= a[n+1]; 
    		}
    	}
    	cout<<result<<endl;
    }
    
    int main()
    {
    	int i,u,v,value;
    	
    	while(scanf("%d%d%d%d",&n,&np,&nc,&m)==4)
    	{
    		memset(cap,0,sizeof(cap));
    		memset(flow,0,sizeof(flow));
    
    		for(i=1;i<=m;i++)
    		{
    			scanf(" (%d,%d)%d",&u,&v,&value);
    			cap[u+1][v+1] += value;
    		}
    		for(i=1;i<=np;i++)
    		{
    			scanf(" (%d)%d",&u,&value);
    			cap[0][u+1] += value;
    		}
    		for(i=1;i<=nc;i++)
    		{
    			scanf(" (%d)%d",&v,&value);
    			cap[v+1][n+1] += value;
    		}
    		Edmonds_Karp();  
    	}
    	return 0;
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    解题:POI 2009 TAB
    解题:POI 2015 Pieczęć
    解题:POI 2013 Taxis
    解题:POI 2015 Kinoman
    题目1012:畅通工程(并查集)
    并查集深入分析
    题目1186:打印日期(日期计算)
    C/C++如何整行读入字符串?
    四种方法解决最大连续子序列和问题
    题目1011:最大连续子序列
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4899592.html
Copyright © 2011-2022 走看看