zoukankan      html  css  js  c++  java
  • POJ 1416:Shredding Company

    Shredding Company
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 4713   Accepted: 2714

    Description

    You have just been put in charge of developing a new shredder for the Shredding Company Although a "normal" shredder would just shred sheets of paper into little pieces so that the contents would become unreadable, this new shredder needs to have the following unusual basic characteristics. 

    1.The shredder takes as input a target number and a sheet of paper with a number written on it. 

    2.It shreds (or cuts) the sheet into pieces each of which has one or more digits on it. 

    3.The sum of the numbers written on each piece is the closest possible number to the target number, without going over it. 

    For example, suppose that the target number is 50, and the sheet of paper has the number 12346. The shredder would cut the sheet into four pieces, where one piece has 1, another has 2, the third has 34, and the fourth has 6. This is because their sum 43 (= 1 + 2 + 34 + 6) is closest to the target number 50 of all possible combinations without going over 50. For example, a combination where the pieces are 1, 23, 4, and 6 is not valid, because the sum of this combination 34 (= 1 + 23 + 4 + 6) is less than the above combination's 43. The combination of 12, 34, and 6 is not valid either, because the sum 52 (= 12 + 34 + 6) is greater than the target number of 50. 
     
    Figure 1. Shredding a sheet of paper having the number 12346 when the target number is 50


    There are also three special rules : 

    1.If the target number is the same as the number on the sheet of paper, then the paper is not cut. 

    For example, if the target number is 100 and the number on the sheet of paper is also 100, then 

    the paper is not cut. 

    2.If it is not possible to make any combination whose sum is less than or equal to the target number, then error is printed on a display. For example, if the target number is 1 and the number on the sheet of paper is 123, it is not possible to make any valid combination, as the combination with the smallest possible sum is 1, 2, 3. The sum for this combination is 6, which is greater than the target number, and thus error is printed. 

    3.If there is more than one possible combination where the sum is closest to the target number without going over it, then rejected is printed on a display. For example, if the target number is 15, and the number on the sheet of paper is 111, then there are two possible combinations with the highest possible sum of 12: (a) 1 and 11 and (b) 11 and 1; thus rejected is printed. In order to develop such a shredder, you have decided to first make a simple program that would simulate the above characteristics and rules. Given two numbers, where the first is the target number and the second is the number on the sheet of paper to be shredded, you need to figure out how the shredder should "cut up" the second number. 

    Input

    The input consists of several test cases, each on one line, as follows : 

    tl num1 
    t2 num2 
    ... 
    tn numn 
    0 0 

    Each test case consists of the following two positive integers, which are separated by one space : (1) the first integer (ti above) is the target number, (2) the second integer (numi above) is the number that is on the paper to be shredded. 

    Neither integers may have a 0 as the first digit, e.g., 123 is allowed but 0123 is not. You may assume that both integers are at most 6 digits in length. A line consisting of two zeros signals the end of the input. 

    Output

    For each test case in the input, the corresponding output takes one of the following three types : 

    sum part1 part2 ... 
    rejected 
    error 

    In the first type, partj and sum have the following meaning : 

    1.Each partj is a number on one piece of shredded paper. The order of partj corresponds to the order of the original digits on the sheet of paper. 

    2.sum is the sum of the numbers after being shredded, i.e., sum = part1 + part2 +... 

    Each number should be separated by one space. 
    The message error is printed if it is not possible to make any combination, and rejected if there is 
    more than one possible combination. 
    No extra characters including spaces are allowed at the beginning of each line, nor at the end of each line. 

    Sample Input

    50 12346
    376 144139
    927438 927438
    18 3312
    9 3142
    25 1299
    111 33333
    103 862150
    6 1104
    0 0

    Sample Output

    43 1 2 34 6
    283 144 139
    927438 927438
    18 3 3 12
    error
    21 1 2 9 9
    rejected
    103 86 2 15 0
    rejected

    题意是给定一个最多是六位数的纸片,然后给了一个target数字,对这个纸片进行切割得到不同的数字,在这些数字之和 中找到小于等于target的最大数字。

    还有一些其他的小规则:

    切割的时候,如果该纸片上的数字是target,该纸片不能切割。

    如果这个纸片无论怎么切割,数字之和都大于target,输出error。

    如果最佳方案有两种或两种以上,输出rejected。


    排除以上情况,输出最优结果,以及在最优结果下的切割方案。

    又是一道折磨我许久的题。。。

    最优结果能求出,但最佳方案不会弄出来,结果还是发现在dfs中传递数组,见识了不同的dfs,真的是无所不能。这几天被挫的厉害啊。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    #pragma warning(disable:4996)
    using namespace std;
    
    int target, len, maxn, num_max;//数组的最大长度
    int val_final[8], val[8];
    int dis[1000000];
    string shre;
    
    void dfs(int x, int sum, int c)
    {
    	if (x > len - 1)
    	{
    		if (maxn < sum)
    		{
    			maxn = sum;
    			num_max = c;
    			for (int i = 0; i < c; i++)
    			{
    				val_final[i] = val[i];
    			}
    		}
    		dis[sum]++;
    		return;
    	}
    	else
    	{
    		int i, t = 0;
    		for (i = x; i < len; i++)
    		{
    			t = t * 10 + shre[i] - '0';
    			if (sum + t <= target)
    			{
    				val[c] = t;
    				dfs(i + 1, sum + t, c + 1);
    			}
    			else
    				break;
    		}
    	}
    }
    
    int main()
    {
    	int i, t;
    	while (cin>>target>>shre)
    	{
    		if (target == 0 && shre == "0")
    			break;
    		memset(dis, 0, sizeof(dis));
    		memset(val_final, 0, sizeof(val_final));
    		memset(val, 0, sizeof(val));
    		t = 0;
    		len = shre.length();
    		maxn = -1;
    
    		for (i = 0; i < len; i++)
    		{
    			t += shre[i] - '0';
    		}
    		if (t > target)
    		{
    			cout << "error" << endl;
    			continue;
    		}
    		
    		dfs(0, 0, 0);
    
    		if (dis[maxn] != 1)
    		{
    			cout << "rejected" << endl;
    		}
    		else
    		{
    			cout << maxn;
    			int k;
    			for (k = 0; k < num_max; k++)
    			{
    				cout << " " << val_final[k];
    			}
    			cout << endl;
    		}
    	}
    	return 0;
    }
    




    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    Tomcat使用经验
    JAVA异常及其异常处理方式
    微信小程序开发笔记(七)--template模板
    微信小程序开发笔记(六)--实现tab选项卡
    微信小程序开发笔记(五)--swiper实现tab选项卡
    微信小程序开发笔记(四)--轮播图
    微信小程序开发笔记(三)--底部导航栏,顶部标题栏设置
    微信小程序开发笔记(二)
    微信小程序开发笔记(一)
    校门外的树
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4899593.html
Copyright © 2011-2022 走看看