zoukankan      html  css  js  c++  java
  • POJ No.3617【B008】

    【B007】Best Cow Line【难度B】————————————————————————————————————————————————

    【Description    支持原版从我做起!!!】

     FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

    The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

    FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

    FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

    Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

    【Input】

     * Line 1: A single integer: N
     * Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

    【Output】

     The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

    【Sample Input】

    6
    ACDBCB
    

     【Sample Output】

    ABCBCD
    

     【Source】

      USACO 2007 November Silver

    【分析】

     题目大意:给定长度为N的字符串S,要构造一个长度为N的字符串T。

                   你可以对T干这些事情(要搞事情(⊙o⊙)哦)

                       *从S的头部移动一个字符到T的尾部

                       *从S的尾部移动一个字符到T的尾部

                   构造一个字典序尽可能小的T哦。

    真正的分析:这要运用贪心的思想,简而言之就是:

                     *取S开头和结尾中较小的一个放到T的末尾

                     (咳咳,基本正确,但还差一点......)

                      那么,这是正确的:
                      *按照字典序比较S和将S翻转之后的s

                      *如果S较小就从S的开头取出一个文字,追加到T的末尾。

                      *否则反之

                      *你——悟到了么?    By wxjor

    【代码】

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<algorithm>
    using namespace std;
    const int maxn=2000;
    int n;
    char S[maxn+1];
    int main()
    {
    	cin>>n;
    	cin>>S;
    	int a=0,b=n-1;
    	while(a<=b)
    	{
            bool left=false;
            for(int i=0;a+i<=b;i++)
            {
    	        if(S[a+i]<S[b-i])
    			{
    		        left=true;
    		        break;
    		    }
    		    else if(S[a+i]>S[b-i])
    		    {
    		        left=false;
    		        break;
    			}
    		} 
    		if(left) putchar(S[a++]);
    		else putchar(S[b--]);
    	}
    	//system("pause");
    	return 0;
    }
    
  • 相关阅读:
    redis的数据类型与应用场景(二)
    redis的安装与配置(一)
    Spring Security教程 ---- 验证码功能的实现
    Java类文件结构
    实体字符
    前端安全之XSS攻击
    $_SERVER[]数组解析
    php主要用于哪几方面
    集群与分布式概念
    python操作mongodb实例
  • 原文地址:https://www.cnblogs.com/lijiaxin-blog-cpp/p/6223959.html
Copyright © 2011-2022 走看看