zoukankan      html  css  js  c++  java
  • HDU-1019 Least Common Multiple

    Description

    The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

    Input

    Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

    Output

    For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

    Sample Input

    2

    3 5 7 15

    6 4 10296 936 1287 792 1

    Sample Output

    105

    10296


    最小公倍数等于两数相乘除以最大公因数。(欧几里得算法)

    #include <iostream>
    #include <cmath>
    #include <algorithm>
    using namespace std;
    
    int main(void)
    {
        int t;
        long func(long, long);
        
        cin >> t;
        while(t--)
        {
            long long q = 1;
            int m;
            long num;
    
            
            cin >> m;
            while(m--)
            {
                cin >> num;
                q = num/func(q, num)*q;
            }
            cout << q << endl;
            
        }
        
        return 0;
    }
    
    
    long func(long a, long b)
    {
        long q = max(a, b);
        long p = a+b-q;
        
        while(q%p!=0)
        {
            p = q+p;
            q = p-q;
            p = p-q;
            p = p%q;
        }
        return p;
    }
    
  • 相关阅读:
    Redis学习笔记
    Springboot + Tomcat跑项目出现端口被占用的问题
    按层打印二叉树
    打印二叉树的镜像——剑指offer
    判断树的子结构——剑指offer
    实习半个月的感想
    使用KMP算法判断是否为旋转词
    微信双开
    win10 右键添加cmd当前目录打开
    勒索邮件
  • 原文地址:https://www.cnblogs.com/limyel/p/6690945.html
Copyright © 2011-2022 走看看