zoukankan      html  css  js  c++  java
  • PAT1008

    1008. Elevator (20)

    时间限制

    400 ms

    内存限制

    65536 kB

    代码长度限制

    16000 B

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors

    在我们城市最高的建筑只有一部电梯。一个请求的列表由N个正整数组成。这些数字代表

    the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor.

    电梯在那一层将会停下,按指定的顺序。电梯移动上一层需要花费6秒,电梯下一层需要花费4秒。

    The elevator will stay for 5 seconds at each stop.

    电梯每一次停下的时候会停5秒。

    For a given request list, you are to compute the total time spent to fulfill the requests on the list.

    对于给出的列表,你要计算出执行这个请求总共花费的时间。

    The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    电梯将会总第0层开始并且在执行请求的执行完成之后不需要返回地面这一层。

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

    每一个输入文件包含一个测试案例。每个案例包含一个正数N,之后有N个正数,所有输入的数都小于100

    Output Specification:

    For each test case, print the total time on a single line.

    对于每一个测试案例,在一行打印出总共的时间。

    Sample Input:

    3 2 3 1
     
    测试案例解释
    2*6 + 5 = 17
    1*6 + 5 = 11
    2*4 + 5 = 13
    17+11+13 = 41
     

    Sample Output:

    41
    
     
     
    题目解析:
    这道题目本身就超级简单,但是之所以还是要写,就是因为第一遍交我错了。
    #include<cstdio>
    #include<cstdlib>
    #include<iostream>
    #include<algorithm>
    
    using namespace std;
    
    int main()
    {
        int n;
        int sum=0,now=0,temp=0;
        cin >> n;
        while (n--)
        {
            cin>>temp;
            if(temp > now)
                sum += (temp-now)*6 + 5;
            else if(temp < now)
                sum += (now-temp)*4 + 5;
            else
                sum += 5;
            now=temp;
        }
        cout<<sum<<endl;
        return 0;  
    }
     
     
    很多朋友都是直接就
    if(temp > now) sum += (temp-now)*6 + 5; 
    else  sum += (now-temp)*4 + 5;
    然后就啥也不管的对了
     
    我为啥要写那么多呢?
    就是因为我错,是因为我考虑的还不够周全,当前后两个数一样的时候是应该加5秒的
    虽然我觉得这非常不合理,在实际的电梯应该没有出现这样的情况
    但是确实,如果不加这5秒就会错误
    所以考虑事情还是需要把所有的情况都考虑在内
    并且分析清楚,很多小题会忽视这个问题,在大题目上面暴露出来就完了
     
  • 相关阅读:
    VC++ 在Watch窗口显示GetLastError值以及详细信息
    VC++ Debug内存值
    VC++ 给你的代码强制加一个硬断点
    wchat_t与char互转
    使用forever运行nodejs应用
    C++ 检查Windows服务运行状态
    【转】Android横竖屏重力自适应
    可配置多功能门 SN74LVC1G57, 1G58, 1G97, 1G98, 1G99
    VPW协议解析
    STM32的TAMPER-RTC管脚作为Tamper使用
  • 原文地址:https://www.cnblogs.com/linkstar/p/5640597.html
Copyright © 2011-2022 走看看