zoukankan      html  css  js  c++  java
  • Just a Hook-HDU1698(线段树求区间)

    http://acm.hdu.edu.cn/showproblem.php?pid=1698

    Problem Description
    In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



    Now Pudge wants to do some operations on the hook.

    Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
    The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

    For each cupreous stick, the value is 1.
    For each silver stick, the value is 2.
    For each golden stick, the value is 3.

    Pudge wants to know the total value of the hook after performing the operations.
    You may consider the original hook is made up of cupreous sticks.
     
    Input
    The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
    For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
    Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
     
    Output
    For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
     
    Sample Input
    1 10 2 1 5 2 5 9 3
     
    Sample Output
    Case 1: The total value of the hook is 24.
     
     
    题目大意:
     
    有一根棍,现在要给他表面镀上一层金属,(本身这根棍是铜的)
    铜的价值是1
    银得价值是2
    金的价值是3
    求最后的价值是多少。
     
    分析:
    用一个变量e表示这一段节点价值
    如果这一段节点有两种金属就让e=-1;
     
     
    #include<stdio.h>
    #include<math.h>
    #include<algorithm>
    #include<iostream>
    #include<string.h>
    #include<stdlib.h>
    using namespace std;
    #define N 101000
    #define Lson r<<1
    #define Rson r<<1|1
    
    struct node
    {
        int L,R,e;
        bool is;
        int mid()
        {
            return (L+R)/2;
        }
        int len()
        {
            return R-L+1;
        }
    }a[N*4];
    
    void BuildTree(int r,int L,int R)
    {
        a[r].L=L;
        a[r].R=R;
        a[r].e=1;
        if(L==R)
        {
            return;
        }
        BuildTree(Lson,L,a[r].mid());
        BuildTree(Rson,a[r].mid()+1,R);
    }
    int Qurry(int r)
    {
        if(a[r].e!=-1)
            return a[r].len()*a[r].e;
        else
            return Qurry(Lson)+Qurry(Rson);
    }
    void Update(int r,int L,int R,int e)
    {
    
        if(a[r].L==L && a[r].R==R)
        {
            a[r].e=e;
            return;
        }
        if(a[r].e!=-1)
        {
            a[Lson].e=a[Rson].e=a[r].e;
        }
        a[r].e=-1;
        if(R<=a[r].mid())
            Update(Lson,L,R,e);
        else if(L>a[r].mid())
            Update(Rson,L,R,e);
        else
        {
            Update(Lson,L,a[r].mid(),e);
            Update(Rson,a[r].mid()+1,R,e);
        }
    }
    int main()
    {
        int T,n,m,i,t,x,y,e;
        scanf("%d",&T);
        t=1;
        while(T--)
        {
            scanf("%d",&n);
            BuildTree(1,1,n);
            scanf("%d",&m);
            for(i=1;i<=m;i++)
            {
    scanf(
    "%d %d %d",&x,&y,&e); Update(1,x,y,e); } printf("Case %d: The total value of the hook is %d. ",t++,Qurry(1)); } return 0; }
  • 相关阅读:
    AJ学IOS(26)UI之iOS抽屉效果小Demo
    AJ学IOS(25)UI之触摸事件
    AJ学IOS(24)UI之注册案例
    AJ学IOS(23)UI之控制器管理
    AJ学IOS(22)UI之UIApplicationDelegate和UIWindow
    AJ学IOS(21)UIApplication设置程序图标右上⾓红⾊数字_联⺴指⽰器等
    AJ学IOS(20)UI之UIPickerView_点菜系统
    AJ学IOS(19)UI之QQ好友列表
    AJ学IOS(18)UI之QQ聊天布局_键盘通知实现自动弹出隐藏_自动回复
    AJ整理问题之:copy,对象自定义copy 什么是property
  • 原文地址:https://www.cnblogs.com/linliu/p/4956828.html
Copyright © 2011-2022 走看看