zoukankan      html  css  js  c++  java
  • POJ 1995(有关快速幂运算的一道水题)

    Raising Modulo Numbers
    Time Limit: 1000MS Memory Limit: 30000K
    Total Submissions: 9745 Accepted: 5921

    Description

    People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow: 

    Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers. 

    You should write a program that calculates the result and is able to find out who won the game. 

    Input

    The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

    Output

    For each assingnement there is the only one line of output. On this line, there is a number, the result of expression 

    (A1B1+A2B2+ ... +AHBH)mod M.

    Sample Input

    3
    16
    4
    2 3
    3 4
    4 5
    5 6
    36123
    1
    2374859 3029382
    17
    1
    3 18132
    

    Sample Output

    2
    13195
    13

    参考代码:

    #include<iostream>
    #include<stdio.h>
    using namespace std;
    typedef long long ll;
    ll mod_pow(ll x,ll n,ll mod)//快速幂运算
    {
        ll res=1;
        while(n>0)
        {
            if(n&1)res=res*x%mod;
            x=x*x%mod;
            n>>=1;
        }
        return res;
    }
    int MOD;
    int N;
    int A,B;
    int main()
    {
        //freopen("C://Users/Administrator/Desktop/acm.txt","r",stdin);
        int test;
        cin>>test;
        ll ans=0;
        while(test--)
        {
            ans=0;
          cin>>MOD>>N;
            while(N--)
            {
                cin>>A>>B;
                ans=(ans+mod_pow(A,B,MOD))%MOD;
            }
            cout<<ans<<endl;
        }
        return 0;
    }




  • 相关阅读:
    第十三周课程总结
    第十二周课程总结
    第十一周课程总结
    第十周课程总结
    第九周课程总结&实验报告(七)
    第八周课程总结&实验报告(六)
    第七周课程总结&实验报告(五)
    第六周学习总结&java实验报告四
    2019秋Java学期课程总结
    2019Java第十四周课程总结
  • 原文地址:https://www.cnblogs.com/linruier/p/9485189.html
Copyright © 2011-2022 走看看