zoukankan      html  css  js  c++  java
  • Lake Counting(深搜妙解)

    Lake Counting
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 16840   Accepted: 8548

    Description

    Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

    Given a diagram of Farmer John's field, determine how many ponds he has.

    Input

    * Line 1: Two space-separated integers: N and M 

    * Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

    Output

    * Line 1: The number of ponds in Farmer John's field.

    Sample Input

    10 12
    W........WW.
    .WWW.....WWW
    ....WW...WW.
    .........WW.
    .........W..
    ..W......W..
    .W.W.....WW.
    W.W.W.....W.
    .W.W......W.
    ..W.......W.

    Sample Output

    3

    Hint

    OUTPUT DETAILS: 

    There are three ponds: one in the upper left, one in the lower left,and one along the right side.

    Source

     
     
    /*
    思路:从任一W开始,不停把邻接部分用'.'代替。调用n次dfs就有n个积水。
    */
    #include<iostream>
    #define MAX 101
    
    using namespace std;
    
    int N,M;
    char field[MAX][MAX];
    
    void dfs(int x, int y)
    {
        field[x][y] = '.';
    
        for(int dx = -1; dx <=1; dx++)for(int dy = -1; dy <=1; dy++)
        {
            int nx = x + dx, ny = y + dy;
    
            if(0<=nx && nx<N && 0<=ny && ny<=M && field[nx][ny]=='W') dfs(nx, ny);
        }
    }
    
    
    int main()
    {
        int ans=0,i,j;
    
        cin>>N>>M;
    
        for(i=0;i<N;i++)
            for(j=0;j<M;j++)
                cin>>field[i][j];
    
        for(i=0;i<N;i++)for(j=0;j<M;j++)
            if(field[i][j] == 'W')
            {dfs(i, j); ans++;}
    
        cout<<ans<<endl;
    
        /*system("pause");*/
        return 0;
    }
    世上无难事,只要肯登攀。
  • 相关阅读:
    LeetCode24-Swap_Pairs
    LeeCode
    LeetCode3-Longest_Substring_Without_Repeating_Characters
    治愈 JavaScript 疲态的学习计划【转载】
    前端冷知识集锦[转载]
    知道这20个正则表达式,能让你少写1,000行代码[转载]
    关于简历和面试【整理自知乎】
    正念冥想方法
    一些职场经验【转载自知乎】
    犹太复国计划向世界展现了一个不一样的民族——观《犹太复国血泪史》有感
  • 原文地址:https://www.cnblogs.com/littlehoom/p/3428343.html
Copyright © 2011-2022 走看看