zoukankan      html  css  js  c++  java
  • 奇偶剪枝

    Tempter of the Bone

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 60673    Accepted Submission(s): 16589


    Problem Description
    The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

    The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
     
    Input
    The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

    'X': a block of wall, which the doggie cannot enter; 
    'S': the start point of the doggie; 
    'D': the Door; or
    '.': an empty block.

    The input is terminated with three 0's. This test case is not to be processed.
     
    Output
    For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
     
    Sample Input
    4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
     
    Sample Output
    NO YES
    #include<iostream>
    #define MAX 10
    using namespace std;
    char maze[MAX][MAX];
    int sx, sy, ex, ey, n, m, t;
    int dx[4] = { 0, 0, 1, -1 }, dy[4] = { 1, -1, 0, 0 };
    bool out = false;
    bool dfs(int x, int y, int sum){
        if (sum > t)return false;
        if (sum == t&&x == ex&&y == ey){ out = true; return true; }
        if (out)return true;
        //奇偶剪枝
        int temp = abs(ex - x) + abs(ey - y);
        if (temp % 2 != (t - sum) % 2)return false;
    
        for (int i = 0; i < 4; i++){
            int nx = x + dx[i], ny = y + dy[i];
            if (0 <= nx&&nx < n && 0 <= ny&&ny < m&&maze[nx][ny] != 'X'){
                maze[nx][ny] = 'X';
                dfs(nx, ny, sum + 1);
                maze[nx][ny] = '.';
            }
        }
        return false;
    }
    int main()
    {
        while (cin >> n >> m >> t){
            if (n + m + t == 0)break;
            for (int i = 0; i < n; i++){
                for (int j = 0; j < m; j++){
                    cin >> maze[i][j];
                    if (maze[i][j] == 'S'){
                        sx = i;
                        sy = j;
                    }
                    if (maze[i][j] == 'D'){
                        ex = i;
                        ey = j;
                    }
                }
            }
            maze[sx][sy] = 'X';
            out = false;
            //奇偶剪枝
            int temp = abs(ex - sx) + abs(ey - sy);
            if (temp % 2 != t % 2){
                cout << "NO" << endl;
                continue;
            }
            for (int i = 0; i < 4; i++){
                int x = sx + dx[i], y = sy + dy[i];
                if (!out&&0 <= x&&x < n && 0 <= y&&y < m&&maze[x][y] != 'X'){
                    maze[x][y] = 'X';
                    dfs(x, y, 1);
                    maze[x][y] = '.';
                }
            }
            if (out){
                cout << "YES" << endl;
            }
            else{
                cout << "NO" << endl;
            }
        }
        return 0;
    }
    世上无难事,只要肯登攀。
  • 相关阅读:
    eclipse本地覆盖版本库
    数据库表分区
    oracle监听器启动,实例启动
    Mac 终端命令大全
    Mac基本用法
    wen前端学习计划
    css3animation模仿百度音乐的唱片旋转效果
    获取HTML DOM节点元素的方法的总结
    简单CSS技巧实现的Logo动画效果(很像导航栏上经常运用的效果,但有差别)
    详解 CSS 属性
  • 原文地址:https://www.cnblogs.com/littlehoom/p/3560398.html
Copyright © 2011-2022 走看看