zoukankan      html  css  js  c++  java
  • PAT Advanced 1019 General Palindromic Number (20 分)

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b2, where it is written in standard notation with k+1 digits ai​​ as (. Here, as usual, 0 for all i and ak​​ is non-zero. Then N is palindromic if and only if ai​​=aki​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

    Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers N and b, where 0 is the decimal number and 2 is the base. The numbers are separated by a space.

    Output Specification:

    For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "ak​​ ak1​​ ... a0​​". Notice that there must be no extra space at the end of output.

    Sample Input 1:

    27 2
    

    Sample Output 1:

    Yes
    1 1 0 1 1
    

    Sample Input 2:

    121 5
    

    Sample Output 2:

    No
    4 4 1
    

    鸣谢网友“CCPC拿不到牌不改名”修正数据!

    #include<iostream>
    #include<vector>
    using namespace std;
    int main() {
        int a,b;
        cin>>a>>b;
        vector<int> vec;
        bool no=false;
        while(a!=0){
            vec.push_back(a%b);
            a/=b;
        }
        for(int i=0;i<vec.size()/2;i++){
            if(vec[i]!=vec[vec.size()-1-i]){
                no=true;
            }
        }
        if(no) cout<<"No"<<endl;
        else cout<<"Yes"<<endl;
        for(int i=vec.size()-1;i>0;i--){
            cout<<vec[i]<<" ";
        }
        cout<<vec[0]<<endl;
        system("pause");
        return 0;
    }
  • 相关阅读:
    Java IO流
    Java中Char和Byte的区别
    Java常用类
    View
    3 View
    View
    3 View
    3 View视图 URLconf
    2 Model层
    2 Model层-模型成员
  • 原文地址:https://www.cnblogs.com/littlepage/p/11296353.html
Copyright © 2011-2022 走看看