zoukankan      html  css  js  c++  java
  • PAT Advanced 1027 Colors in Mars (20 分)

    People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

    Input Specification:

    Each input file contains one test case which occupies a line containing the three decimal color values.

    Output Specification:

    For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

    Sample Input:

    15 43 71
    

    Sample Output:

    #123456



    #include<iostream>
    using namespace std;
    char toChar(int a){
        switch(a){
            case 10:return 'A';break;
            case 11:return 'B';break;
            case 12:return 'C';break;
            default:return a+'0';
        }
    }
    int main() {
        int a,b,c;
        cin>>a>>b>>c;
        cout<<"#"<<toChar(a/13)<<toChar(a%13)<<toChar(b/13)<<toChar(b%13)<<toChar(c/13)<<toChar(c%13);
        system("pause");
        return 0;
    }

    注意大于10进制都需要一个toChar函数

  • 相关阅读:
    JavaScript高级第01天笔记
    JavaScript基础第06天笔记
    JavaScript基础第05天笔记
    JavaScript基础第04天笔记
    JavaScript基础第03天笔记
    JavaScript基础第02天笔记
    JavaScript基础第01天笔记
    03-CSS文字文本样式
    CSS第二天笔记
    浮动
  • 原文地址:https://www.cnblogs.com/littlepage/p/11296389.html
Copyright © 2011-2022 走看看