zoukankan      html  css  js  c++  java
  • PAT Advanced 1006 Sign In and Sign Out (25分)

    At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

    Input Specification:

    Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

    ID_number Sign_in_time Sign_out_time
    
     

    where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

    Output Specification:

    For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

    Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

    Sample Input:

    3
    CS301111 15:30:28 17:00:10
    SC3021234 08:00:00 11:25:25
    CS301133 21:45:00 21:58:40
    
     

    Sample Output:

    SC3021234 CS301133

    简单的查找最大最小值

    #include <iostream>
    using namespace std;
    int main()
    {
        int M;cin>>M;
        string maxid,_max="",minid,_min="1111 1111",tmp,start,_end;
        while(M--){
            cin>>tmp>>start>>_end;
            if(start<_min) {
                _min=start;
                minid=tmp;
            }
            if(_end>_max) {
                _max=_end;
                maxid=tmp;
            }
        }
        cout<<minid<<" "<<maxid;
        system("pause");
        return 0;
    }
  • 相关阅读:
    Android 中Service生命周期
    Android开发中退出程序几种方法
    FLAG_ACTIVITY_CLEAR_TOP和FLAG_ACTIVITY_REORDER_TO_FRONT用法
    【Java并发编程实战】-----synchronized
    The specified child already has a parent错误
    使用Ant打包工具 基本介绍
    what's WSDL
    XFire WebService demo
    jws webservice code
    axis、xfire、CXF 、JWS
  • 原文地址:https://www.cnblogs.com/littlepage/p/12215708.html
Copyright © 2011-2022 走看看