zoukankan      html  css  js  c++  java
  • PAT Advanced 1008 Elevator (20分)

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

    Output Specification:

    For each test case, print the total time on a single line.

    Sample Input:

    3 2 3 1
    
     

    Sample Output:

    41

    题目大意:电梯上楼需要6s,下楼需要4s,中间停靠5秒,给出1个N,给出N个数字,然后进行计算电梯停靠时间


    #include <iostream>
    using namespace std;
    int main()
    {
        int N,level=0,tmp,sum=0;
        cin>>N;
        while(N--){
            cin>>tmp;
            if(tmp>level) sum=sum+(tmp-level)*6+5;
            else sum=sum+(level-tmp)*4+5;
            level=tmp;
        }
        cout<<sum;
        system("pause");
        return 0;
    }
     
  • 相关阅读:
    几种常见排序算法
    62.Android之各分辨率定义的图片规格
    MVC
    EasyUI datebox 只读和取值
    WebForm带有图片的验证码
    WebForm水印照片
    ajax完整结构
    jquery简单动画
    webform数据导出
    WebForm 发送邮箱
  • 原文地址:https://www.cnblogs.com/littlepage/p/12215741.html
Copyright © 2011-2022 走看看