zoukankan      html  css  js  c++  java
  • PAT Advanced 1064 Complete Binary Search Tree (30分)

    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    • The left subtree of a node contains only nodes with keys less than the node's key.
    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
    • Both the left and right subtrees must also be binary search trees.

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    10
    1 2 3 4 5 6 7 8 9 0
    
     

    Sample Output:

    6 3 8 1 5 7 9 0 2 4

    已知一组数据,我们需要进行构成满二叉排序树,并且打印层序遍历。

    我们可以进行sort一下,就是中序遍历,然后进行中序遍历插入数据即可。

    #include <iostream>
    #include <vector>
    #include <algorithm>
    using namespace std;
    int N, index_v = 0 ;
    vector<int> v, res;
    void inorder(int index_res){
        if(index_res >= N) return ;
        inorder(2 * index_res + 1);
        res[index_res] = v[index_v++];
        inorder(2 * index_res + 2);
    }
    int main(){
        cin >> N;
        v.resize(N);
        res.resize(N);
        for(int i = 0; i < N; i++)
            cin >> v[i];
        sort(v.begin(),v.end());
        inorder(0);
        cout << res[0];
        for(int i = 1; i < N; i++)
            cout << " " << res[i];
        system("pause");
        return 0;
    }
  • 相关阅读:
    黄聪:WordPress动作钩子函数add_action()、do_action()源码解析
    黄聪:使用WORDPRESS自带AJAX方法
    黄聪:get_posts 函数 | wordpress
    黄聪:wordpress伪静态的原理
    黄聪:wordpress如何开启文章格式post format
    黄聪:Xmind修改默认字体风格设置
    黄聪:让WordPress主题支持语言本地化(使用poedit软件实现中文翻译功能)
    ArcGIS Pro二次开发-选择gdb
    arcgis pro2.5 改变地图范围
    创建用户SQL
  • 原文地址:https://www.cnblogs.com/littlepage/p/12234101.html
Copyright © 2011-2022 走看看