zoukankan      html  css  js  c++  java
  • PAT Advanced 1070 Mooncake (25分)

    Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

    Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤), the number of different kinds of mooncakes, and D (≤ thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

    Sample Input:

    3 200
    180 150 100
    7.5 7.2 4.5
    
     

    Sample Output:

    9.45

    这道题考察了贪心,我们进行按照单价进行排序后计算即可

    #include <iostream>
    #include <vector>
    #include <algorithm>
    using namespace std;
    struct mooncake {
        double cnt, price;
    };
    vector<mooncake> v;
    bool cmp(mooncake mc, mooncake mc2) {
        return mc.price * mc2.cnt < mc2.price * mc.cnt;
    }
    int main() {
        double N, target;
        scanf("%lf %lf", &N, &target);
        v.resize(N);
        for(int i = 0; i < N; i++)
            scanf("%lf", &v[i].price);
        for(int i = 0; i < N; i++)
            scanf("%lf", &v[i].cnt);
        sort(v.begin(), v.end(), cmp);
        double ans = 0;
        for(int i = 0; i < N && target != 0; i++){
            if(v[i].price <= target){
                target -= v[i].price;
                ans += v[i].cnt;
            }else {
                ans += (target * v[i].cnt / v[i].price);
                target = 0;
            }
        }
        printf("%.2f", ans);
        return 0;
    }
  • 相关阅读:
    SAP中主数据和单据的删除
    如何在kubernetes中使用Spring Cloud微服务
    认识AngularJs
    最全面的水平居中方案跟flexbox布局
    浅谈背景图片的填充
    Html、Css、JavaScript、Dom细节总结
    innerText跟innerHtml的区别
    解决悬浮的<header>、<footer>遮挡内容的处理技巧
    怎样发布NodeJs项目
    安装grunt
  • 原文地址:https://www.cnblogs.com/littlepage/p/12252046.html
Copyright © 2011-2022 走看看