zoukankan      html  css  js  c++  java
  • PAT Advanced 1048 Find Coins (25分)

    Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 1 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤, the total number of coins) and M (≤, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the two face values V1​​ and V2​​ (separated by a space) such that V1​​+V2​​=M and V1​​V2​​. If such a solution is not unique, output the one with the smallest V1​​. If there is no solution, output No Solution instead.

    Sample Input 1:

    8 15
    1 2 8 7 2 4 11 15
    
     

    Sample Output 1:

    4 11
    
     

    Sample Input 2:

    7 14
    1 8 7 2 4 11 15
    
     

    Sample Output 2:

    No Solution

    题意:找出两个硬币和为给定值。理解:寻找计数,每次遍历,进行减一操作。

    #include <iostream>
    #include <map>
    using namespace std;
    int main() {
        int N, M, tmp;
        map<int, int> m;
        scanf("%d%d", &N, &M);
        while(N--) {
            scanf("%d", &tmp);
            m[tmp]++;
        }
        for(auto it = m.begin(); it != m.end(); it++) {
            it->second--;
            if(m[M - it->first]) {
                printf("%d %d", it->first, M - it->first);
                return 0;
            }
        }
        printf("No Solution");
        return 0;
    }
  • 相关阅读:
    新项目反思
    nei网访问
    react
    css沉默
    沉默
    node准备
    C++学习(八):删除文件
    利用工具格式化日期文本
    PageHelper 记录总条数不正确问题处理
    tk.mybatis 多个or条件拼接
  • 原文地址:https://www.cnblogs.com/littlepage/p/12268386.html
Copyright © 2011-2022 走看看