zoukankan      html  css  js  c++  java
  • PAT Advanced 1061 Dating (20分)

    Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

    Input Specification:

    Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

    Output Specification:

    For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week -- that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

    Sample Input:

    3485djDkxh4hhGE 
    2984akDfkkkkggEdsb 
    s&hgsfdk 
    d&Hyscvnm
    
     

    Sample Output:

    THU 14:04

    考察范围,范围一定要缩到最小,以及,格式化必须完全正确

    #include <iostream>
    using namespace std;
    int main() {
        string a, b, c, d;
        cin >> a >> b >> c >> d;
        int i = 0;
        for(;; i++) if(a[i] == b[i] && a[i] >= 'A' && a[i] <= 'G') break;
        switch(a[i]) {
            case 'A': printf("MON "); break;
            case 'B': printf("TUE "); break;
            case 'C': printf("WED "); break;
            case 'D': printf("THU "); break;
            case 'E': printf("FRI "); break;
            case 'F': printf("SAT "); break;
            case 'G': printf("SUN "); break;
        }
        while(++i) if(a[i] == b[i] && ((isdigit(a[i]) || (a[i] >= 'A' && a[i] <= 'N')))) break;
        if(isdigit(a[i])) printf("%02d:", a[i] - '0');
        else printf("%02d:", a[i] - 'A' + 10);
        for(i = 0;; i++) if(c[i] == d[i] && isalpha(c[i])) break;
        printf("%02d", i);
        system("pause");
        return 0;
    }
  • 相关阅读:
    mouseOver与rollOver
    排序二叉树
    发展
    bitmapData
    回调与事件
    遍历舞台上所有对象
    面向对象原则
    面向对象的三大特征(个人理解)
    面向对象出现原因以及意义
    OC语言BLOCK和协议
  • 原文地址:https://www.cnblogs.com/littlepage/p/12269317.html
Copyright © 2011-2022 走看看