zoukankan      html  css  js  c++  java
  • 1147 Heaps (30分)

    In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

    Your job is to tell if a given complete binary tree is a heap.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

    Output Specification:

    For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

    Sample Input:

    3 8
    98 72 86 60 65 12 23 50
    8 38 25 58 52 82 70 60
    10 28 15 12 34 9 8 56
    
     

    Sample Output:

    Max Heap
    50 60 65 72 12 23 86 98
    Min Heap
    60 58 52 38 82 70 25 8
    Not Heap
    56 12 34 28 9 8 15 10

    一直一个树,我们要判断是最大堆,最小堆,还是不是堆,并且打印后序遍历。

    通过0位和1位确定堆是如何的,然后进行判断其他节点是否符合,不符合打印不是,否则打印是

    #include <iostream>
    using namespace std;
    int M, N, tree[2000], judge, start;
    void dfs(int index) {
        if(2 * index + 1 < N) {
            if(judge == 1 && tree[index] < tree[2 * index + 1]) judge = -1;
            if(judge == 0 && tree[index] > tree[2 * index + 1]) judge = -1;
            dfs(2 * index + 1);
        }
        if(2 * index + 2 < N) {
            if(judge == 1 && tree[index] < tree[2 * index + 2]) judge = -1;
            if(judge == 0 && tree[index] > tree[2 * index + 2]) judge = -1;
            dfs(2 * index + 2);
        }
    }
    void post(int index) {
        if(index >= N) return;
        post(2 * index + 1);
        post(2 * index + 2);
        if(start) {
            printf("%d", tree[index]);
            start = !start;
        } else printf(" %d", tree[index]);
    }
    int main() {
        cin >> M >> N;
        while(M--) {
            for(int i = 0; i < N; i++) cin >> tree[i];
            judge = tree[0] > tree[1]; // judge 1 大根 0 根 -1 不是
            dfs(0);
            if(judge == 1) cout << "Max Heap" << endl;
            else if(judge == 0) cout << "Min Heap" << endl;
            else cout << "Not Heap" << endl;
            start = 1;
            post(0);
            cout << endl;
        }
        return 0;
    }
  • 相关阅读:
    站立会议04(第二阶段)附加站立会议02、03
    第二阶段冲刺---站立会议01
    网络:Session原理及存储
    网络:Xen理解
    网络:LVS负载均衡原理
    网络:OSPF理解
    语音笔记:信号分析
    语音笔记:CTC
    语音笔记:矢量量化
    语音笔记:MFCC
  • 原文地址:https://www.cnblogs.com/littlepage/p/12817987.html
Copyright © 2011-2022 走看看