zoukankan      html  css  js  c++  java
  • 1138 Postorder Traversal (25分)

    Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

    Sample Input:

    7
    1 2 3 4 5 6 7
    2 3 1 5 4 7 6
    
     

    Sample Output:

    3

    已知先序中序求后序

    #include <iostream>
    using namespace std;
    int pre[99999], in[99999], post[99999], c = 0, N;
    void postorder(int root, int start, int end) {
        if(start > end) return;
        int i = start;
        while(i < end && in[i] != pre[root]) i++;
        postorder(root + 1, start, i - 1);
        postorder(root + 1, i + 1, end);
        post[c++] = in[i];
    }
    int main() {
        scanf("%d", &N);
        for(int i = 0; i < N; i++)
            scanf("%d", &pre[i]);
        for(int i = 0; i < N; i++)
            scanf("%d", &in[i]);
        postorder(0, 0, N - 1);
        printf("%d", post[0]);
        return 0;
    }
  • 相关阅读:
    cmder 基本配置和使用
    apache开启.htaccess及.htaccess的使用方法
    PHP 伪静态规则写法RewriteRule-htaccess详细语法使用
    Oracle创建分区表
    Oracle基础知识
    SQLPLUS
    linux上使用docker安装oracle
    使用IDEA创建可执行jar
    Hyper-V-问题整理
    spring的容器管理
  • 原文地址:https://www.cnblogs.com/littlepage/p/12822433.html
Copyright © 2011-2022 走看看