zoukankan      html  css  js  c++  java
  • 1104 Sum of Number Segments (20分)

    Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

    Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 1. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

    Output Specification:

    For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

    Sample Input:

    4
    0.1 0.2 0.3 0.4
    
     

    Sample Output:

    5.00

    考察数学,我们需要在草稿纸上进行求和公式的计算。

    #include<cstdio>
    #include<vector>
    using namespace std;
    int main() {
        int N;
        scanf("%d", &N);
        vector<double> data(N, 0.0);
        for (int i = 0; i < N; i++)
            scanf("%lf", &data[i]);
        double result = 0.0;
        for (int i = 0; i < N; i++)
            result += data[i] * (N - i)*(i + 1);
        printf("%.2f", result);
    }
  • 相关阅读:
    24点游戏算法
    汉诺塔算法
    台阶算法
    质因数分解算法
    全排列递归算法
    DFS 深度优先搜索例题
    容器
    数细胞
    C++栈和队列
    C++STL中vector容器 begin()与end()函数、front()与back()的用法
  • 原文地址:https://www.cnblogs.com/littlepage/p/12875974.html
Copyright © 2011-2022 走看看