zoukankan      html  css  js  c++  java
  • 武汉科技大学ACM :1008: A+B for Input-Output Practice (VIII)

    Problem Description

    Your task is to calculate the sum of some integers.

    Input

    Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 

    Output

    For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

    Sample Input

    3
    4 1 2 3 4
    5 1 2 3 4 5
    3 1 2 3

    Sample Output

    10
    
    15
    
    6
    

    #include <iostream>  
    using namespace std;  
      
    int main()  
    {  
        int N;  
        cin >> N;  
        while (N--)  
        {  
            int M,sum = 0;  
            cin >> M;  
            while (M--)  
            {  
                int i;  
                cin >> i;  
                sum += i;  
            }  
            cout << sum << endl;  
            if (N != 0)cout << endl;//没有此行运行时会出现错误:Presentation Error  
        }  
      
    return 0;  
    }  
  • 相关阅读:
    Car HDU
    Defeat the Enemy UVALive
    Alice and Bob HDU
    Gone Fishing POJ
    Radar Installation POJ
    Supermarket POJ
    Moo Volume POJ
    Text Document Analysis CodeForces
    checkbox全选与反选

  • 原文地址:https://www.cnblogs.com/liuwt365/p/4147462.html
Copyright © 2011-2022 走看看