zoukankan      html  css  js  c++  java
  • UVA 10106 Product (大数相乘)

    Product 

    The Problem

    The problem is to multiply two integers X, Y. (0<=X,Y<10250)

    The Input

    The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

    The Output

    For each input pair of lines the output line should consist one integer the product.

    Sample Input

    12
    12
    2
    222222222222222222222222
    

    Sample Output

    144
    444444444444444444444444
    


    大数相乘,网上有非常多模板,今下午练练手,自己写一遍,刚開始忽略了前置0。导致0*12=00,0*123=000,后来改了输出就ac了。

    #include <iostream>
    #include <cstring>
    #define maxn 260
    using namespace std;
    int main()
    {
        char str1[maxn],str2[maxn];
        while(cin>>str1>>str2)
    	{		
    		int len1,len2;
    		len1=strlen(str1);
    		len2=strlen(str2);
    		
    		int s1[maxn],s2[maxn];
    		memset(s1,0,sizeof(s1));
    		memset(s2,0,sizeof(s2));
    		
    		int i;
    		for(i=0;i<len1;i++)
    			s1[i]=str1[i]-'0';
    		for(i=0;i<len2;i++)
    			s2[i]=str2[i]-'0';
    		
    		int sum[maxn+maxn];
    		memset(sum,0,sizeof(sum));
    		int j,k;
    		for(i=len2-1;i>=0;i--)
    		{
    			for(j=len1-1;j>=0;j--)
    			{
    				sum[i+j+1]=sum[i+j+1]+s2[i]*s1[j];
    			}
    		}
    		for(k=len1+len2-1;k>=0;k--)
    			if(sum[k]>=10)
    			{
    				int temp;
    				temp=sum[k]%10;
    				sum[k-1]=sum[k-1]+sum[k]/10;
    				sum[k]=temp;
    			}
    			
    			//if(sum[0]!=0)
    			//	cout<<sum[0];
    			bool flag=0;
    			for(i=0;i<len1+len2-1;i++)
    			{
    				if(sum[i]!=0)
    					flag=1;
    				if(flag==1)
    				cout<<sum[i];
    			}
    			cout<<sum[len1+len2-1];
    			cout<<endl;
    	}
        return 0;
    }
    






  • 相关阅读:
    面向对象和面向过程的区别
    k-means算法
    win10系统下安装mysql
    python并发编程之多进程
    操作系统的概念
    前端基础之html
    聚类分析
    决策树
    Mysql
    SQL练习题
  • 原文地址:https://www.cnblogs.com/llguanli/p/7207162.html
Copyright © 2011-2022 走看看