zoukankan      html  css  js  c++  java
  • hdu-1213-How Many Tables

    How Many Tables

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 25116    Accepted Submission(s): 12523


    Problem Description
    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
     
    Input
    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
     
    Output
    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
     
    Sample Input
    2 5 3 1 2 2 3 4 5 5 1 2 5
     
    Sample Output
    2 4
     

    题目大意:水题计算最后的集合个数。

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1213

    代码:

    #include <iostream>
    
    using namespace std;
    int f[1005];
    int find(int n)
    {
        if(n!=f[n])
        f[n]=find(f[n]);
        return f[n];
    }
    int main()
    {   int t,n,m;
        cin>>t;
    while(t--)
    {
        cin>>n>>m;
        for(int i=1;i<=n;i++)
        f[i]=i;
        int a,b;
        for(int i=0;i<m;i++)
        {
            cin>>a>>b;
            int a1=find(a);
            int b1=find(b);
            f[a1]=b1;
        }
        int t1=0;
        for(int i=1;i<=n;i++)
        if(find(i)==i)
        t1++;
        cout<<t1<<endl;
    }
    
    }
  • 相关阅读:
    JS语法转换-ES6转ES5
    百度编辑器的初步使用
    github使用的小坑 处理
    关于input的检验问题
    一些代码规范(收集)
    jquery源码解析日常
    重操JS旧业第九弹:函数表达式
    重操JS旧业第八弹:面向对象与继承
    重操JS旧业第七弹:面向对象与对象创建
    重操JS旧业第六弹:基本类型包装
  • 原文地址:https://www.cnblogs.com/llsq/p/5880986.html
Copyright © 2011-2022 走看看