zoukankan      html  css  js  c++  java
  • 数论

    There is a hill with n holes around. The holes are signed from 0 to n-1. 



    A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes. 

    Input

    The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648). 

    Output

    For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line. 

    Sample Input

    2
    1 2
    2 2

    Sample Output

    NO
    YES
    #include <stdio.h>
    #include<math.h>
    int gcd(int a,int b)
    {
        return a%b==0?b:gcd(b,a%b);
    }
    int main()
    {
        int p,m,n;
        scanf("%d",&p);
        while(p--)
        {
            scanf("%d%d",&m,&n);
            if(gcd(m,n)==1)
                puts("NO");
            else 
                puts("YES");
        }
        return 0;
    }
  • 相关阅读:
    ACM常用算法及练习(2)
    ACM常用算法及练习(1)
    ACM进阶计划
    《算法艺术与信息学竞赛》题目-提交方式对照表
    ACM之Java速成(4)
    ACM之Java速成(3)
    ACM之Java速成(2)
    ACM之Java速成(1)
    uva 11520
    uva 10755
  • 原文地址:https://www.cnblogs.com/lsb666/p/5746954.html
Copyright © 2011-2022 走看看