zoukankan      html  css  js  c++  java
  • poj ID1003

    Problem:

    Description

    How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.


    Input

    The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

    Output

    For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

    Sample Input

    1.00
    3.71
    0.04
    5.19
    0.00
    

    Sample Output

    3 card(s)
    61 card(s)
    1 card(s)
    273 card(s)


    Submission:
    #include<iostream>
    using namespace std;
    int main()
    {
        int i=2;
        float n;
        float sum=0;
        while(cin>>n&&n!=0.00)
        {      
           i=2; 
           sum=0;                        
           while(sum<=n)
           {
              sum=sum+1.00/i;
              i++;
            }
            cout<<i-2<<" card(s)"<<endl;
        }   
           return 0;
    }

    这次没有那么那么顺利,稍微有点细节上的问题,sum每次循环之后都应该重新赋值为0,否则的话,只会一次一次的累加,结果就会出问题。另外输出的那一行结果,card前面是有一个空格的,少了的话,也是不能ac的,细节,还是细节!

    
    
  • 相关阅读:
    cmd常用命令
    快捷键
    leetcode:Sort List(一个链表的归并排序)
    leetcode:Merge Two Sorted Lists(有序链表的归并)
    leetcode:Search for a Range(数组,二分查找)
    leetcode:Search a 2D Matrix(数组,二分查找)
    实时操作系统与分时操作系统
    第四章函数作业题,函数模板
    第四章函数作业题,函数的重载
    第四章函数作业题,内置函数
  • 原文地址:https://www.cnblogs.com/lx09110718/p/poj1003.html
Copyright © 2011-2022 走看看