zoukankan      html  css  js  c++  java
  • hdu 1241

    Oil Deposits

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 8264    Accepted Submission(s): 4850


    Problem Description
    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
     
    Input
    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
     
    Output
    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
     
    Sample Input
    1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
     
    Sample Output
    0 1 2 2
     
     
    代码

    #include<stdio.h>
    int directoin[8][2]= {{0,1},{0,-1},{1,0},{-1,0},{1,1},{1,-1},{-1,1},{-1,-1}},n,m;
    char map[110][110];
    void DFS(int x,int y)
    {
    int i,xx,yy;
    for(i=0; i<8; i++)
    {
    xx=x+directoin[i][0];
    yy=y+directoin[i][1];
    if(xx<0||xx>=m||yy<0||yy>=n)
    continue;
    if(map[xx][yy]=='*')
    continue;
    map[xx][yy]='*';
    DFS(xx,yy);
    }
    }
    int main()
    {
    int i,j,count;
    while(~scanf("%d%d",&m,&n)&&m+n)
    {
    count=0;
    for(i=0; i<m; i++)
    scanf("%s",map[i]);
    for(i=0; i<m; i++)
    for(j=0; j<n; j++)
    {
    if(map[i][j]=='@')
    {
    DFS(i,j);
    count++;
    }
    }
    printf("%d ",count);
    }
    }

  • 相关阅读:
    页面生命周期
    设计模式
    算法
    window服务
    Xml
    sql声明变量,及if else语句、while语句的用法
    SQL 使用临时表和临时变量完成update表字段实际案例
    SQL Server遍历表的几种方法
    node快速构建express项目
    词法分析
  • 原文地址:https://www.cnblogs.com/lxm940130740/p/3256460.html
Copyright © 2011-2022 走看看