zoukankan      html  css  js  c++  java
  • hdu1060

    Leftmost Digit

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 10997    Accepted Submission(s): 4209


    Problem Description
    Given a positive integer N, you should output the leftmost digit of N^N.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single positive integer N(1<=N<=1,000,000,000).
     
    Output
    For each test case, you should output the leftmost digit of N^N.
     
    Sample Input
    2
    3
    4
     
    Sample Output
    2
    2
    Hint
    In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
    In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
     
    分析:
    m=n^n,两边分别对10取对数得 log10(m)=n*log10(n),
    得m=10^(n*log10(n)),由于10的任何整数次幂首位一定为1,
    所以m的首位只和n*log10(n)的小数部分有关
     
    #include<stdio.h>
    #include<math.h>
    int main()
    {
        int n,t;
        double a,a1,a2;
        scanf("%d", &t);
        while (t--)
        {
            scanf("%d",&n);
            a=n*log10(n*1.0);
            a1=a-(__int64)a;
            a2=pow(10.0,a1);
            printf("%d ", (int)a2);
        }
        return 0;
    }
  • 相关阅读:
    H3C 路由策略(人为打环)
    linux nfs配置
    linux vsftp 简单配置
    linux vg lv pv
    linux sshd 登录不需要密码
    linux dhcp 简单配置
    linux pxe 安装Centos7
    分别使用laravel安装器和composer安装laravel!
    阻止按钮快速点击
    检测页面是否允许使用Flash
  • 原文地址:https://www.cnblogs.com/lxm940130740/p/3284630.html
Copyright © 2011-2022 走看看