zoukankan      html  css  js  c++  java
  • hdu2199

    Can you solve this equation?

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 6176    Accepted Submission(s): 2889


    Problem Description
    Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
    Now please try your lucky.
     
    Input
    The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
     
    Output
    For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
     
    Sample Input
    2
    100
    -4
     
    Sample Output
    1.6152
    No solution!
     
    思路:浮点型的二分法
     
    代码:
    #include<iostream>
    #include<stdio.h>
    using namespace std;
    double y;
    int main()
    {
        int t;
        scanf("%d",&t);
        while(t--)
        {
            scanf("%lf",&y);
            if(6<=y&&y<=807020306)
            {
                double m,l,r;
                l=0;
                r=100;
                while(r-l>1e-6)
                {
                    m=(l+r)/2;
                    if(8*m*m*m*m+7*m*m*m+2*m*m+3*m+6<y)
                        l=m+1e-7;
                    else
                        r=m-1e-7;
                }
                printf("%.4lf ",(l+r)/2.0);
            }
            else
                printf("No solution! ");
        }
        return 0;
    }
  • 相关阅读:
    Sort
    RAID
    LeetCode总结 -- 一维动态规划篇
    Count and Say
    Dynamic Programming Introduction
    Mongodb与Redis应用指标对比
    精通有状态vs无状态(Stateful vs Stateless)—Immutable模式之姐妹篇
    Windows 安装 pytorch3d
    GitHub 图片无法显示 或 gist 无法访问
    LaTeX符号表,数学公式速查必备
  • 原文地址:https://www.cnblogs.com/lxm940130740/p/3442126.html
Copyright © 2011-2022 走看看