zoukankan      html  css  js  c++  java
  • An Easy Task

    描述

    Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

    Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

    Note: if year Y is a leap year, then the 1st leap year is year Y.

    输入

    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains two positive integers Y and N(1<=N<=10000).

    输出

    For each test case, you should output the Nth leap year from year Y.

    样例输入

    3
    2005 25
    1855 12
    2004 10000

    样例输出

    2108
    1904
    43236

    code :

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    bool isLoop(int y){
        if((y%4==0 && y%100!=0) || y%400==0){
          return true;
        }
        return false;
    }
    int main()
    {
        int t, y, n;
        cin>>t;
        while(t--){
           cin>>y>>n;
           while(n){
                if(isLoop(y)){
                    n--;
                }
                y++;
             }
             cout<<y-1<<endl;
        }
    
     return 0;
    }
    

      

  • 相关阅读:
    day21继承
    day22
    面向对象
    常用模块
    模块
    迭代器
    【游记】2020-CSP
    【初赛解析】2021CSP-S初赛解析(不完全)
    【题解】AcWing 1390.通电围栏
    【题解】AcWing 1387.家的范围
  • 原文地址:https://www.cnblogs.com/lzeffort/p/5925519.html
Copyright © 2011-2022 走看看