zoukankan      html  css  js  c++  java
  • POJ 1195 Mobile phones

    Mobile phones
    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 12394   Accepted: 5710

    Description

    Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

    Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

    Input

    The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 

    The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

    Table size: 1 * 1 <= S * S <= 1024 * 1024 
    Cell value V at any time: 0 <= V <= 32767 
    Update amount: -32768 <= A <= 32767 
    No of instructions in input: 3 <= U <= 60002 
    Maximum number of phones in the whole table: M= 2^30 

    Output

    Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

    Sample Input

    0 4
    1 1 2 3
    2 0 0 2 2 
    1 1 1 2
    1 1 2 -1
    2 1 1 2 3 
    3
    

    Sample Output

    3
    4
    分析:二维树状数组
    #include <stdio.h>
    
    #define  MAXNUM 1050
    
    int Map[MAXNUM][MAXNUM];
    
    int lowbit(int x)
    {
        return x & -x;
    }
    
    void add(int x, int y, int num, int n)
    {
        for (int i = x; i <= n; i += lowbit(i))
        {
            for (int j = y; j <= n; j += lowbit(j))
            {
                Map[i][j] += num;
            }
        }
    }
    
    int getsum(int x, int y)
    {
        int sum = 0;
        for (int i = x; i > 0; i -= lowbit(i))
        {
            for (int j = y; j > 0; j -= lowbit(j))
            {
                sum += Map[i][j];
            }
        }
        return sum;
    }
    
    int main()
    {
        int n,x1, y1, x2, y2, s, num;
        while(scanf("%d", &s))
        {
            if (s == 3)
            {
                break;
            }
            if (s == 0)
            {
                scanf("%d", &n);
            }
            else
            {
                if (s == 1)
                {
                    scanf("%d%d%d", &x1, &y1, &num);
                    add(x1 + 1, y1 + 1, num, n);
                }
                else
                {
                    if (s == 2)
                    {
                        scanf("%d%d%d%d", &x1, &y1, &x2, &y2);
                        int sum = getsum(x1, y1) + getsum(x2 + 1, y2 + 1) - getsum(x1, y2 + 1) - getsum(x2 + 1, y1);
                        printf("%d\n", sum);
                    }
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    Office 2007在安装过程中出错-解决办法
    Sql日期时间格式转换
    大型网站架构演变和知识体系
    作为一个web开发人员,哪些技术细节是在发布站点前你需要考虑到的
    Java 入门基础
    技术类面试、笔试题汇总
    怎样玩转千万级别的数据
    数据库性能优化:SQL索引
    最后一公里极速配送
    编辑-滴滴算法大赛算法解决过程
  • 原文地址:https://www.cnblogs.com/lzmfywz/p/3113151.html
Copyright © 2011-2022 走看看