zoukankan      html  css  js  c++  java
  • POJ 3461 Oulipo

    Oulipo
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 16111   Accepted: 6482

    Description

    The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

    Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

    Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

    So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

    Input

    The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

    • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
    • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

    Output

    For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

    Sample Input

    3
    BAPC
    BAPC
    AZA
    AZAZAZA
    VERDI
    AVERDXIVYERDIAN

    Sample Output

    1
    3
    0
    题目大意:求一个字符串中另一个字符串出现的次数
    #include <stdio.h>
    #include <string>
    #include <string.h>
    #include <cstring>
    using namespace std;
    int arr[1000005];
    char str1[1000005];
    char str2[1000005];
    
    void getindex(char deststr[], int index[])
    {
        int nLen = strlen(deststr);
        int k = -1;
        int j = 0;
        index[0] = -1;
        while(j < nLen)
        {
            if (k == -1 || deststr[k] == deststr[j])
            {
                k++;
                j++;
                index[j] = k;
            }
            else
            {
                k = index[k];
            }
        }
    }
    
    int KMP(char srcstr[], char deststr[])
    {
        int nLen1 = strlen(srcstr);
        int nLen2 = strlen(deststr);
        getindex(deststr, arr);
        int i = 0;
        int j = 0;
        int nCount = 0;
        while(i < nLen1)
        {
            if (srcstr[i] == deststr[j] || j == -1)
            {
                i++;
                j++;
                if (j == nLen2)
                {
                    nCount ++;
                }
            }
            else
            {
                j = arr[j];
            }
        }
        return nCount;
    }
    
    
    int main()
    {
        int n;
        scanf("%d", &n);
        for (int i = 0; i < n; i++)
        {
            scanf("%s%s", str1, str2);
            printf("%d\n", KMP(str2, str1));
        }
        return 0;
    }
  • 相关阅读:
    1123 Is It a Complete AVL Tree (30分)---如何建立平衡二叉搜索树(LL型RR型LR型RL型)+如何判断完全二叉树
    1021 Deepest Root (25 分)(经典搜索)
    PAT甲 1020 Tree Traversals (树的后序中序->层序)
    (数据结构)如何根据树的后序中序遍历求树的前序遍历
    习题2.3 数列求和-加强版 (模拟)
    PAT甲级 1051 Pop Sequence (25) && 2019天梯赛 L2-032 彩虹瓶 (25 分) (模拟+栈)
    PAT甲级 Are They Equal (25) (恶心模拟)
    PAT甲级1059 Prime Factors (25)(素数筛+求一个数的质因子)
    IO 模型
    Nginx 反向代理
  • 原文地址:https://www.cnblogs.com/lzmfywz/p/3113999.html
Copyright © 2011-2022 走看看