zoukankan      html  css  js  c++  java
  • POJ 2752 Seek the Name, Seek the Fame

    Seek the Name, Seek the Fame
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 9446   Accepted: 4516

    Description

    The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

    Step1. Connect the father's name and the mother's name, to a new string S. 
    Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

    Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

    Input

    The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

    Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

    Output

    For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

    Sample Input

    ababcababababcabab
    aaaaa
    

    Sample Output

    2 4 9 18
    1 2 3 4 5
    题目大意:求某一个字符串的相等的前后缀长度,并按照长度从小到大输出
    #include <stdio.h>
    #include <string.h>
    using namespace std;
    
    int next[400005];
    char str[400005];
    int Count[400005];
    
    void getnext()
    {
        int k = -1;
        int j = 0;
        next[0] = -1;
        int nLen = strlen(str);
        while(j < nLen)
        {
            if (k == -1 || str[j] == str[k])
            {
                k++;
                j++;
                next[j] = k;
            }
            else
            {
                k = next[k];
            }
        }
    }
    
    void print(int nLen)
    {
        if (next[nLen] != 0)
        {
            print(next[nLen]);
            printf("%d ", next[nLen]);
        }
    }
    
    int main()
    {
        while (scanf("%s", str) != EOF)
        {
            getnext();
            int nLen = strlen(str);
            print(nLen);
            printf("%d\n", nLen);
        }
        return 0;
    }
  • 相关阅读:
    diary and html 文本颜色编辑,行距和其它编辑总汇
    bash coding to changeNames
    virtualbox ubuntu 网络连接 以及 连接 secureCRT
    linux 学习6 软件包安装
    linux 学习8 权限管理
    vim 使用2 转载 为了打开方便
    ubuntu
    linux 学习15 16 启动管理,备份和恢复
    linux 学习 14 日志管理
    linux 学习 13 系统管理
  • 原文地址:https://www.cnblogs.com/lzmfywz/p/3114221.html
Copyright © 2011-2022 走看看