zoukankan      html  css  js  c++  java
  • POJ 2403 Hay Points

    Hay Points
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 5735   Accepted: 3695

    Description

    Each employee of a bureaucracy has a job description - a few paragraphs that describe the responsibilities of the job. The employee's job description, combined with other factors, such as seniority, is used to determine his or her salary. 
    The Hay Point system frees the Human Resources department from having to make an intelligent judgement as to the value of the employee; the job description is merely scanned for words and phrases that indicate responsibility. In particular, job descriptions that indicate control over a large budget or management over a large number of people yield high Hay Point scores. 

    You are to implement a simplified Hay Point system. You will be given a Hay Point dictionary and a number of job descriptions. For each job description you are to compute the salary associated with the job, according to the system.

    Input

    The first line of input contains 2 positive integers: m <= 1000, the number of words in the Hay Point dictionary, and n <= 100, the number of job descriptions. m lines follow; each contains a word (a string of up to 16 lower-case letters) and a dollar value (a integer number between 0 and 1,000,000). Following the dictionary are the n job descriptions. Each job description consists of one or more lines of text; for your convenience the text has been converted to lower case and has no characters other than letters, numbers, and spaces. Each job description is terminated by a line containing a period.

    Output

    For each job description, output the corresponding salary computed as the sum of the Hay Point values for all words that appear in the description. Words that do not appear in the dictionary have a value of 0.

    Sample Input

    7 2
    administer 100000
    spending 200000
    manage 50000
    responsibility 25000
    expertise 100
    skill 50
    money 75000
    the incumbent will administer the spending of kindergarden milk money
    and exercise responsibility for making change he or she will share
    responsibility for the task of managing the money with the assistant
    whose skill and expertise shall ensure the successful spending exercise
    .
    this individual must have the skill to perform a heart transplant and
    expertise in rocket science
    .
    

    Sample Output

    700150
    150
    #include <stdio.h>
    #include <iostream>
    #include <map>
    #include <string>
    #include <cstring>
    using namespace std;
    
    int main()
    {
        map<string, int> item;
        int m, n, val;
        string temp;
        cin>>m>>n;
        int ans = 0;
        for (int i = 0; i < m; i++)
        {
            cin>>temp>>val;
            item.insert(make_pair<string, int>(temp, val));
        }
        for (int i = 0; i < n; i++)
        {
            ans = 0;
            while(cin>>temp)
            {
                if (temp[0] == '.')
                {
                    cout<<ans<<endl;
                    break;
                }
                else
                {
                    ans += item[temp];
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    【C#】3.算法温故而知新
    【C#】2.算法温故而知新
    【C#】1.算法温故而知新
    【C#】SQL数据库助手类2.0(自用)
    【Javascript Demo】JS获取当前对象大小以及屏幕分辨率等
    【Android 基础】Android中全屏或者取消标题栏
    【ASP.NET 问题】System.InvalidOperationException: 对象的当前状态使该操作无效 【大量表单数据提交】错误解决
    【CSS】颜色码对照表
    【Ext.Net学习笔记】07:后续
    【Ext.Net学习笔记】06:Ext.Net GridPanel的用法(GridPanel 折叠/展开行、GridPanel Selection、 可编辑的GridPanel)
  • 原文地址:https://www.cnblogs.com/lzmfywz/p/3167985.html
Copyright © 2011-2022 走看看