zoukankan      html  css  js  c++  java
  • ZOJ Problem Set 3202 Secondprice Auction


    Time Limit: 1 Second      Memory Limit: 32768 KB

    Do you know second-price auction? It's very simple but famous. In a second-price auction, each potential buyer privately submits, perhaps in a sealed envelope or over a secure connection, his (or her) bid for the object to the auctioneer. After receiving all the bids, the auctioneer then awards the object to the bidder with the highest bid, and charges him (or her) the amount of the second-highest bid.

    Suppose you're the auctioneer and you have received all the bids, you should decide the winner and the amount of money he (or she) should pay.

    Input

    There are multiple test cases. The first line of input contains an integer T(T <= 100), indicating the number of test cases. Then T test cases follow.

    Each test case contains two lines: The first line of each test case contains only one integer N, indicating the number of bidders. (2 <= N <= 100) The second line of each test case contains N integers separated by a space. The i-th integer Pi indicates the i-th bidder's bid. (0 < Pi <= 60000) You may assume that the highest bid is unique.

    Output

    For each test case, output a line containing two integers x and y separated by a space. It indicates that the x-th bidder is the winner and the amount of money he (or she) should pay is y.

    Sample Input

    2
    3
    3 2 1
    2
    4 9
    

    Sample Output

    1 2
    2 4
    
    #include<iostream>
    using namespace std;
    
    int main(void)
    {
    	int cases;cin>>cases;
    	while(cases--)
    	{
    		int bidders;
    		int winner = 0, seconder = 0, bidderIndex = 0;
    		cin>>bidders;
    		for(int index = 1; index <= bidders; index++)
    		{
    			int bidder;cin>>bidder;
    			if(bidder > winner)
    			{
    				if(winner > seconder)
    					seconder = winner;
    				winner = bidder;
    				bidderIndex = index;
    			}else if(bidder > seconder)
    				seconder = bidder;
    		}
    		cout<<bidderIndex<<" "<<seconder<<endl;
    	}
    	return 0;
    }
    

      

  • 相关阅读:
    vue指令(3)v-html
    vue指令(2)v-text
    vue基础(2)模板语法
    Struts2中在Action里面向前端页面传值的方法总结
    MySQL之字符串函数
    搜索关键字描红
    点击超链接执行js代码实现确认操作
    Java之线程同步的三种方法
    Java之线程的控制
    Java之线程的生命周期
  • 原文地址:https://www.cnblogs.com/malloc/p/2665732.html
Copyright © 2011-2022 走看看