zoukankan      html  css  js  c++  java
  • ZOJ Problem Set 3202 Secondprice Auction


    Time Limit: 1 Second      Memory Limit: 32768 KB

    Do you know second-price auction? It's very simple but famous. In a second-price auction, each potential buyer privately submits, perhaps in a sealed envelope or over a secure connection, his (or her) bid for the object to the auctioneer. After receiving all the bids, the auctioneer then awards the object to the bidder with the highest bid, and charges him (or her) the amount of the second-highest bid.

    Suppose you're the auctioneer and you have received all the bids, you should decide the winner and the amount of money he (or she) should pay.

    Input

    There are multiple test cases. The first line of input contains an integer T(T <= 100), indicating the number of test cases. Then T test cases follow.

    Each test case contains two lines: The first line of each test case contains only one integer N, indicating the number of bidders. (2 <= N <= 100) The second line of each test case contains N integers separated by a space. The i-th integer Pi indicates the i-th bidder's bid. (0 < Pi <= 60000) You may assume that the highest bid is unique.

    Output

    For each test case, output a line containing two integers x and y separated by a space. It indicates that the x-th bidder is the winner and the amount of money he (or she) should pay is y.

    Sample Input

    2
    3
    3 2 1
    2
    4 9
    

    Sample Output

    1 2
    2 4
    
    #include<iostream>
    using namespace std;
    
    int main(void)
    {
    	int cases;cin>>cases;
    	while(cases--)
    	{
    		int bidders;
    		int winner = 0, seconder = 0, bidderIndex = 0;
    		cin>>bidders;
    		for(int index = 1; index <= bidders; index++)
    		{
    			int bidder;cin>>bidder;
    			if(bidder > winner)
    			{
    				if(winner > seconder)
    					seconder = winner;
    				winner = bidder;
    				bidderIndex = index;
    			}else if(bidder > seconder)
    				seconder = bidder;
    		}
    		cout<<bidderIndex<<" "<<seconder<<endl;
    	}
    	return 0;
    }
    

      

  • 相关阅读:
    PPT中的图像失真
    Delphi GDI对象之绘制文本
    iOS App的加固保护原理
    PHP网站渗透中的奇技淫巧:检查相等时的漏洞
    企业安全建设之浅谈数据防泄露
    常见分布式全局唯一ID生成策略及算法的对比
    写时模式”与“读时模式”之间的对比
    工业互联网环境下IT/OT融合的安全防御技术研究
    一文梳理工业控制系统信息安全软件与监控
    威努特iSoc培训
  • 原文地址:https://www.cnblogs.com/malloc/p/2665732.html
Copyright © 2011-2022 走看看