zoukankan      html  css  js  c++  java
  • Packet Tracer 5.0实验(十) 路由器OSPF动态路由配置

    一、实验目标

    • 掌握OSPF协议的配置方法;
    • 掌握查看通过动态路由协议OSPF学习产生的路由;
    • 熟悉广域网线缆的连接方式;

    二、实验背景

    假设某公司通过一台三层交换机连到公司出口路由器上,路由器再和公司外的另一台路由器连接。现要做适当配置,实现公司内部主机与公司外部主机之间的相互通信。为了简化网管的管理维护工作,公司决定采用OSPF协议实现互通。

    三、技术原理

    OSPF开放式最短路径优先协议,是目前网络中应用最广泛的路由协议之一。属于内部网关路由协议,能够适应各种规模的网络环境,是典型的链路状态协议。OSPF路由协议通过向全网扩散设备的链路状态信息,使网络中每台设备最终同步一个具有全网链路状态的数据库,然后路由器采用SPF算法,以自己为根,计算到达其他网络的最短路径,最终形成全网路由信息。

    四、实验步骤

    实验拓扑

    1、在三层交换机上划分VLAN10和VLAN20,其中VLAN10用于连接校园网主机,VLAN20用于连接R1;

    2、路由器之间通过V.35电缆通过串口连接,DCE端连接在R1上,配置其时间频率为64000;

    3、主机和交换机通过直连线连接,主机与路由器通过交叉线连接;

    4、在S3560上配置OSPF路由协议;

    5、在路由器R1、R2上配置OSPF路由协议;

    6、将PC1、PC2主机默认网关分别设置为与直连网络设备接口IP地址;

    7、验证PC1、PC2主机之间可以互相通信;

    S3560:

    Switch>en
    Switch#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#hostname S3560
    S3560(config)#vlan 10
    S3560(config-vlan)#exit
    S3560(config)#vlan 20
    S3560(config-vlan)#exit
    S3560(config)#interface fa0/10
    S3560(config-if)#switchport access vlan 10
    S3560(config-if)#exit
    S3560(config)#interface fa0/20
    S3560(config-if)#switchport access vlan 20
    S3560(config-if)#exit
    S3560(config)#interface vlan 10
    S3560(config-if)#
    %LINK-5-CHANGED: Interface Vlan10, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
    
    S3560(config-if)#ip address 192.168.1.1 255.255.255.0
    S3560(config-if)#exit
    S3560(config)#interface vlan 20
    
    %LINK-5-CHANGED: Interface Vlan20, changed state to up
    S3560(config-if)#ip address 192.168.3.1 255.255.255.0
    S3560(config-if)#exit
    S3560(config)#router ospf ?
      <1-65535>  Process ID
    S3560(config)#router ospf 1
    S3560(config-router)#network 192.168.1.0 ?
      A.B.C.D  OSPF wild card bits
    S3560(config-router)#network 192.168.1.0 0.0.0.255 ?
      area  Set the OSPF area ID
    S3560(config-router)#network 192.168.1.0 0.0.0.255 area ?
      <0-4294967295>  OSPF area ID as a decimal value
      A.B.C.D         OSPF area ID in IP address format
    S3560(config-router)#network 192.168.1.0 0.0.0.255 area 0
    S3560(config-router)#network 192.168.3.0 0.0.0.255 area 0 S3560(config-router)#end S3560# %SYS-5-CONFIG_I: Configured from console by console S3560#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route Gateway of last resort is not set C 192.168.1.0/24 is directly connected, Vlan10 C 192.168.3.0/24 is directly connected, Vlan20 S3560# 00:10:01: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.4.1 on Vlan20 from LOADING to FULL, Loading Done S3560#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route Gateway of last resort is not set C 192.168.1.0/24 is directly connected, Vlan10 O 192.168.2.0/24 [110/783] via 192.168.3.2, 00:00:00, Vlan20 C 192.168.3.0/24 is directly connected, Vlan20 O 192.168.4.0/24 [110/782] via 192.168.3.2, 00:01:40, Vlan20 S3560#

    R1:

    Router>en
    Router#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#hostname R1
    R1(config)#interface fa0/0
    R1(config-if)#no shutdown 
    
    R1(config-if)#
    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    
    R1(config-if)#ip address 192.168.3.2 255.255.255.0
    R1(config-if)#exit
    R1(config)#interface serial 2/0
    R1(config-if)#no shutdown 
    
    %LINK-5-CHANGED: Interface Serial2/0, changed state to down
    R1(config-if)#clock rate 64000
    R1(config-if)#ip address 192.168.4.1 255.255.255.0
    R1(config-if)#exit
    R1(config)#router ospf 1
    R1(config-router)#network 192.168.3.0 0.0.0.255 area 0
    R1(config-router)#network 192.168.4.0 0.0.0.255 area 0
    R1(config-router)#
    00:09:57: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.3.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
    
    R1(config-router)#end
    
    %SYS-5-CONFIG_I: Configured from console by console
    R1#show ip route 
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
    O    192.168.1.0/24 [110/2] via 192.168.3.1, 00:00:09, FastEthernet0/0
    C    192.168.3.0/24 is directly connected, FastEthernet0/0
    R1#
    %LINK-5-CHANGED: Interface Serial2/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
    
    00:12:53: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.4.2 on Serial2/0 from LOADING to FULL, Loading Done
    
    R1#show ip route 
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
    O    192.168.1.0/24 [110/2] via 192.168.3.1, 00:02:58, FastEthernet0/0
    O    192.168.2.0/24 [110/782] via 192.168.4.2, 00:00:02, Serial2/0
    C    192.168.3.0/24 is directly connected, FastEthernet0/0
    C    192.168.4.0/24 is directly connected, Serial2/0
    R1#

    R2:

    Router>en
    Router#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#hostname R2
    R2(config)#interface fa0/0
    R2(config-if)#no shutdown 
    
    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
    
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    
    R2(config-if)#ip address 192.168.2.1 255.255.255.0
    R2(config-if)#exit
    R2(config)#interface serial 2/0
    R2(config-if)#no shutdown 
    
    %LINK-5-CHANGED: Interface Serial2/0, changed state to up
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
    R2(config-if)#ip address 192.168.4.2 255.255.255.0 R2(config-if)#exit R2(config)#router ospf 1 R2(config-router)#network 192.168.2.0 0.0.0.255 area 0 R2(config-router)#network 192.168.4.0 0.0.0.255 area 0 R2(config-router)#end %SYS-5-CONFIG_I: Configured from console by console R2#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route Gateway of last resort is not set C 192.168.2.0/24 is directly connected, FastEthernet0/0 C 192.168.4.0/24 is directly connected, Serial2/0 R2#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route Gateway of last resort is not set O 192.168.1.0/24 [110/783] via 192.168.4.1, 00:00:01, Serial2/0 C 192.168.2.0/24 is directly connected, FastEthernet0/0 O 192.168.3.0/24 [110/782] via 192.168.4.1, 00:00:01, Serial2/0 C 192.168.4.0/24 is directly connected, Serial2/0 R2#

    五、测试

    Packet Tracer PC Command Line 1.0
    PC>ipconfig
    
    IP Address......................: 192.168.1.2
    Subnet Mask.....................: 255.255.255.0
    Default Gateway.................: 192.168.1.1
    
    PC>ping 192.168.2.2
    
    Pinging 192.168.2.2 with 32 bytes of data:
    
    Reply from 192.168.2.2: bytes=32 time=11ms TTL=125
    Reply from 192.168.2.2: bytes=32 time=15ms TTL=125
    Reply from 192.168.2.2: bytes=32 time=14ms TTL=125
    Reply from 192.168.2.2: bytes=32 time=14ms TTL=125
    
    Ping statistics for 192.168.2.2:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 11ms, Maximum = 15ms, Average = 13ms
    
    PC>
  • 相关阅读:
    LeetCode Ugly Number
    LeetCode Missing Number
    拓扑排序
    不相交集的求并算法(按集合大小求并+按高度求并)
    数据结构排序总结
    基数排序
    java 发展简史
    java 白皮书的关键术语
    包+类导入+静态导入+类放入包中+包作用域
    关于二叉堆(优先队列)的其他操作及其应用
  • 原文地址:https://www.cnblogs.com/mchina/p/2597856.html
Copyright © 2011-2022 走看看