zoukankan      html  css  js  c++  java
  • 1008 Elevator(20 分)

    1008 Elevator(20 分)

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

    Output Specification:

    For each test case, print the total time on a single line.

    Sample Input:

    3 2 3 1
    

    Sample Output:

    41

    #include<stdio.h>
    #include<iostream>
    
    using namespace std;
    
    int main()
    {
        int N;
        cin >> N;
    
        int a[100];//记录停留的楼层
        for(int i = 0;i < N;i++)
        {
            cin >> a[i];
        }
    
        int sum = a[0]*6 + 5;//总时间
        for(int i = 1;i < N;i++)
        {
            if(a[i] > a[i-1])//上升
            {
                sum += (a[i]-a[i-1])*6 + 5;
            }
            else//下降
            {
                sum += (a[i-1]-a[i])*4 + 5;
            }
        }
    
        cout << sum<<endl;
    
        return 0;
    }


  • 相关阅读:
    PYTHON 函数总结
    PYTHON 模块总结
    python例题21--30
    python例题11--20
    python例题 1--10
    如何选中表格内同类名的某一行?
    table表格td内内容自动换行
    layer弹出层传值到父页面
    DIV内数据删除操作
    锚记搞定窗口滚动
  • 原文地址:https://www.cnblogs.com/meiqin970126/p/9600878.html
Copyright © 2011-2022 走看看