zoukankan      html  css  js  c++  java
  • 2014ACM/ICPC亚洲区域赛牡丹江站现场赛-A ( ZOJ 3819 ) Average Score

    Average Score

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis.

    After a mid-term exam, Bob was anxious about his grade. He went to the professor asking about the result of the exam. The professor said:

    "Too bad! You made me so disappointed."

    "Hummm... I am giving lessons to two classes. If you were in the other class, the average scores of both classes will increase."

    Now, you are given the scores of all students in the two classes, except for the Bob's. Please calculate the possible range of Bob's score. All scores shall be integers within [0, 100].

    Input

    There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

    The first line contains two integers N (2 <= N <= 50) and M (1 <= M <= 50) indicating the number of students in Bob's class and the number of students in the other class respectively.

    The next line contains N - 1 integers A1A2, .., AN-1 representing the scores of other students in Bob's class.

    The last line contains M integers B1B2, .., BM representing the scores of students in the other class.

    Output

    For each test case, output two integers representing the minimal possible score and the maximal possible score of Bob.

    It is guaranteed that the solution always exists.

    Sample Input

    2
    4 3
    5 5 5
    4 4 3
    6 5
    5 5 4 5 3
    1 3 2 2 1
    

    Sample Output

    4 4
    2 4
    

    Author: JIANG, Kai
    Source: The 2014 ACM-ICPC Asia Mudanjiang Regional Contest


    题目链接:Average Score


    解题思路:牡丹江站的签到题!!

    !好恶心,当时在现场,好像快一个小时的时候才出题。太菜了。。。開始还没想到简单的方法,想直接暴力枚举,后来又想了想,直接计算出A班的n-1个人的平均成绩,然后取下界。这就是分数的最大值。再求B班的m个人的平均成绩,取上界。这就是分数的下界。



    AC代码:

    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    #include <algorithm>
    #include <vector>
    #include <queue>
    #include <set>
    #include <map>
    #include <string>
    #include <math.h>
    #include <stdlib.h>
    #include <time.h>
    using namespace std;
    #define INF 0x7fffffff
    
    int main()
    {
        #ifdef sxk
            freopen("in.txt","r",stdin);
        #endif
        int T, n, m, sum, c;
        scanf("%d",&T);
        while(T--)
        {
            sum = 0;
            scanf("%d%d",&n,&m);
            for(int i=0; i<n-1; i++){
                scanf("%d", &c);
                sum += c;
            }
            double ans1 = 1.0*sum/(n-1);
            if(floor(ans1) == ans1)  ans1 --;   
            else ans1 = floor(ans1);       //取下界
            sum = 0;
            for(int i=0; i<m; i++){
                scanf("%d", &c);
                sum += c;
            }
            double ans2 = 1.0*sum/m;
            if(floor(ans2) == ans2)  ans2 ++;   //取上界
            else ans2 = ceil(ans2);
            cout<<ans2<<" "<<ans1<<endl;
        }
        return 0;
    }
    





  • 相关阅读:
    重新整理 .net core 实践篇————配置系统之盟约[五]
    重新整理 .net core 实践篇————依赖注入应用之援军[四]
    重新整理 .net core 实践篇————依赖注入应用之生命法则[三]
    重新整理 .net core 实践篇————依赖注入应用[二]
    重新整理 .net core 实践篇————配置应用[一]
    spring cloud 学习笔记 客户端(本地)均衡负载(三)
    Leetcode之插入区间
    Leetcode之两棵二叉搜索树中的所有元素
    Leetcode之二叉树的层序遍历
    LeetCode之验证二叉搜索树
  • 原文地址:https://www.cnblogs.com/mfmdaoyou/p/6741780.html
Copyright © 2011-2022 走看看