zoukankan      html  css  js  c++  java
  • hdu 2055 An easy problem (java)

    问题:

    開始尝试用字符做数组元素。可是并没实用。

    在推断语句时把a z排出了。


    An easy problem

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 16516    Accepted Submission(s): 11096


    Problem Description
    we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
    Give you a letter x and a number y , you should output the result of y+f(x).
     

    Input
    On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
     

    Output
    for each case, you should the result of y+f(x) on a line.
     

    Sample Input
    6 R 1 P 2 G 3 r 1 p 2 g 3
     

    Sample Output
    19 18 10 -17 -14

    代码:

    import java.util.*;
    
    public class Main{	
    	public static void M1(char str,int kk){
    		char aa[]={'A','B','C','D','E','F','G','H','I','J','K','L','M','N','O','P','Q','R','S','T','U','V','W','X','Y','Z'};										
    		for(int i=0;i<26;i++){	
    			if(aa[i]==str)
    				System.out.println((i+1)+kk);
    		}
    	}		
    	public static void M2(char str,int kk){
    		char aa[]={'a','b','c','d','e','f','g','h','i','j','k','l','m','n','o','p','q','r','s','t','u','v','w','x','y','z'};										
    		for(int i=0;i<26;i++){	
    			if(aa[i]==str)
    				System.out.println(-(i+1)+kk);
    		}
    	}		
    	public static void main(String[] args) {
    		Scanner cin=new Scanner(System.in);
    		int nn=cin.nextInt();
    		for(int ii=0;ii<nn;ii++){
    			String st=cin.next();
    			int kk=cin.nextInt();
    			char a[]=st.toCharArray();
    			char str=a[0];				
    			if(str>='a'&&str<='z')				
    				M2(str,kk);
    			else if(str>='A'&&str<='Z')
    				M1(str,kk);
    
    
    		}
    	}
    }


  • 相关阅读:
    vue 开发环境搭建
    签名算法
    MySQL explain执行计划优化
    查看运行时某个java对象占用JVM大小及通过idea查看java的内存占用情况
    jenkins 配置
    CSS布局
    《JavaScript 代码优化指南》
    JavaScript 跨域漫游
    iFrame 功能详解
    粘性的底部布局
  • 原文地址:https://www.cnblogs.com/mfrbuaa/p/5127031.html
Copyright © 2011-2022 走看看