zoukankan      html  css  js  c++  java
  • POJ 1209 模拟进栈和出栈

    Rails
    Time Limit: 1000MS        Memory Limit: 10000K
    Total Submissions: 31441        Accepted: 12222

    Description
    There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

    The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

    Input
    The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0.

    The last block consists of just one line containing 0.

    Output
    The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

    Sample Input

    5
    1 2 3 4 5
    5 4 1 2 3
    0
    6
    6 5 4 3 2 1
    0
    0

    Sample Output

    Yes
    No

    Yes

    #include <iostream>
    #include <stack>
    #include <cstdio>
    using namespace std;
    
    const int MAXN = 1000+10;
    int n,target[MAXN];
    
    int main()
    {
        int flag2;
       while(scanf("%d",&n)==1)
        {
           while(n!=0){
    
            stack<int> s;
            int A = 1,B = 1;//A为进站车厢车号,B为出战车厢车号(按进站出战顺序排)
            cin>>target[1];
            if(target[1]==0){
                cout<<endl;
                break;
            }
            for(int i = 2;i<=n;i++)
                scanf("%d",&target[i]);
            int flag = 1;
            while(B<=n)
            {
                if(A==target[B])//当前进站的车厢是否等于出站的,相等则直接进站出战,不用压栈
                {
                    A++;
                    B++;
                }
                else if(!s.empty()&&s.top()==target[B])
                {
                    s.pop();
                    B++;
                }
                else if(A<=n)//以上三种都不成立,只有把当前车厢压栈,若没有车厢,则退出
                    s.push(A++);
                else
                {
                    flag=0;
                    break;
                }
            }
                cout<<(flag?"Yes":"No")<<endl;
            }
    
        }
            return 0;
    }
    


  • 相关阅读:
    AOJ 718.计算GPA
    AOJ 11.Rails
    AOJ 592.神奇的叶子
    AOJ 10.目标柏林
    洛谷P1030求先序排列
    vijos1514天才的记忆
    洛谷2016战略游戏
    LOJ10155数字转换
    洛谷2014选课
    洛谷2015二叉苹果树
  • 原文地址:https://www.cnblogs.com/mingrigongchang/p/6246272.html
Copyright © 2011-2022 走看看