zoukankan      html  css  js  c++  java
  • 1084 Broken Keyboard (20 分)(字符串处理)

    On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

    Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

    Input Specification:

    Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or “_” (representing the space). It is guaranteed that both strings are non-empty.

    Output Specification:

    For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

    Sample Input:

    7_This_is_a_test
    hssaes

    Sample Output:

    7TI

    题目大意:

    旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及实际被输入的文字,请你列出肯定坏掉的那些键~

    分析:

    用string的find函数~遍历字符串s1,当当前字符s1[i]不在s2中,它的大写也不在ans中时,将当前字符的大写放入ans中,最后输出ans字符串即可~

    ps:感谢github上的@xiaorong61给我发的pull request中strchr()函数带来的灵感~让我想到了曾经用过的string的find函数~

    原文链接:https://blog.csdn.net/liuchuo/article/details/51994896

    错误思路

    用set呢,确实可以去重,但是他的顺序是字母序的;
    而unordered_set是随机顺序。
    因此,两者都不可。还是乖乖用hash。

    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        string s1,s2;
        unordered_set<char> st;
        cin>>s1>>s2;
        for(int i=0;i<s1.size();i++){
            if(s2.find(s1[i])==string::npos){
                st.insert(toupper(s1[i]));
            }
        }
        for(auto it=st.begin();it!=st.end();it++)
            cout<<*it;
        return 0;
    }
    

    题解

    柳神的思路总是这么简洁明了~

    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        string s1,s2,ans;
        cin>>s1>>s2;
        for(int i=0;i<s1.size();i++){
            if(s2.find(s1[i])==string::npos&&ans.find(toupper(s1[i]))==string::npos){
                ans+=toupper(s1[i]);
            }
        }
        cout<<ans;
        return 0;
    }
    
  • 相关阅读:
    PHP5中PDO的简单使用
    Apache中设置默认首页的方法
    PHP数组读取的循环操作
    header("Location:login.php")应该注意的几个问题
    纯JavaScript实现弹出选择第几个单选按钮
    PHP关于错误抑制符@的使用
    CSS盒子模型
    Appache中的ServerAlias
    PHP move_uploaded_file() 函数 定义和用法
    PHP ob_start() 函数介绍
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15663902.html
Copyright © 2011-2022 走看看