zoukankan      html  css  js  c++  java
  • 1043 Is It a Binary Search Tree (25 分)(二叉查找树BST)

    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    The left subtree of a node contains only nodes with keys less than the node’s key.
    The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
    Both the left and right subtrees must also be binary search trees.
    If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

    Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, first print in a line “YES” if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or “NO” if not. Then if the answer is “YES”, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input 1:

    7
    8 6 5 7 10 8 11

    Sample Output 1:

    YES
    5 7 6 8 11 10 8

    Sample Input 2:

    7
    8 10 11 8 6 7 5

    Sample Output 2:

    YES
    11 8 10 7 5 6 8

    Sample Input 3:

    7
    8 6 8 5 10 9 11

    Sample Output 3:

    NO

    生词

    英文 解释
    recursively 递归地

    题目大意:

    给定一个整数键值序列,现请你编写程序,判断这是否是对一棵二叉搜索树或其镜像进行前序遍历的结果。

    分析:

    假设它是二叉搜索树,一开始isMirror为false,根据二叉搜索树的性质将已知的前序转换为后序,转换过程中,如果发现最后输出的后序数组长度不为n,那就设isMirror为true,然后清空后序数组,重新再转换一次(根据镜面二叉搜索树的性质),如果依旧转换后数组大小不等于n,就输出NO否则输出YES

    原文链接:https://blog.csdn.net/liuchuo/article/details/52160455

    题解






    #include <bits/stdc++.h>
    
    using namespace std;
    struct node
    {
        int data;
        node *left,*right;
    };
    void insert(node* &root,int data)
    {
        if(root==nullptr){
            root=new node;
            root->data=data;
            root->left=root->right=nullptr;
            return;
        }
        if(data<root->data) insert(root->left,data);
        else insert(root->right,data);
    }
    void preOrder(node* root,vector<int>& vi)
    {
        if(root==nullptr) return;
        vi.push_back(root->data);
        preOrder(root->left,vi);
        preOrder(root->right,vi);
    }
    void preMirror(node* root,vector<int>& vi)
    {
        if(root==nullptr) return;
        vi.push_back(root->data);
        preMirror(root->right,vi);
        preMirror(root->left,vi);
    }
    void postOrder(node* root,vector<int>& vi)
    {
        if(root==nullptr) return;
        postOrder(root->left,vi);
        postOrder(root->right,vi);
        vi.push_back(root->data);
    }
    void postMirror(node* root,vector<int>& vi)
    {
        if(root==nullptr) return;
        postMirror(root->right,vi);
        postMirror(root->left,vi);
        vi.push_back(root->data);
    }
    vector<int> origin,pre,preM,post,postM;
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int n,data;
        node* root=nullptr;
        cin>>n;
        for(int i=0;i<n;i++){
            cin>>data;
            origin.push_back(data);
            insert(root,data);
        }
        preOrder(root,pre);
        preMirror(root,preM);
        postOrder(root,post);
        postMirror(root,postM);
        if(origin==pre){
            cout<<"YES"<<endl;
            for(int i=0;i<n-1;i++)
                cout<<post[i]<<" ";
            cout<<post[n-1]<<endl;
        }else if(origin==preM){
            cout<<"YES"<<endl;
            for(int i=0;i<n-1;i++)
                cout<<postM[i]<<" ";
            cout<<postM[n-1]<<endl;
        }else{
            cout<<"NO"<<endl;
        }
        return 0;
    }
    

    本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15763645.html

  • 相关阅读:
    Ubuntu下Geary安装
    (1)html初步--表格的使用
    MYSQL笔记
    三,springboot集成mybatis
    一台服务部署多个tomcat注意事项
    Apache和Tomcat整合(一个Apache 不同域名处理多个不同业务)
    linux 安装 apache
    linux笔记
    关联查询一张小表。对性能有影响吗(mysql)
    关于mysql的临时表并行的问题
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15763645.html
Copyright © 2011-2022 走看看