zoukankan      html  css  js  c++  java
  • IBGP规划

    在IBGP邻居中,使用反射器减少IBGP邻居关系是一种最常用的网络结构,在上图中AS65001中有6台路由器,其中,R1和R2是一组反射器,配置如下:

    R1:

    !

    interface Loopback0

     ip address 10.255.255.1 255.255.255.255

     ip router isis 10

    !

    interface GigabitEthernet1

     ip address 10.10.6.1 255.255.255.252

     ip router isis 10

     negotiation auto

     isis network point-to-point

     isis password cisco

    !

    interface GigabitEthernet2

     ip address 10.10.4.1 255.255.255.252

     ip router isis 10

     negotiation auto

     isis network point-to-point

     isis password cisco

    !

    interface GigabitEthernet3

     ip address 10.10.7.1 255.255.255.252

     ip router isis 10

     negotiation auto

     isis network point-to-point

     isis password cisco

    !

    router isis 10

     net 49.0000.1025.5255.1000.00

     is-type level-2-only

    !

    router bgp 65001

     bgp router-id 10.255.255.1

     bgp cluster-id 10.255.255.1

     bgp log-neighbor-changes

     bgp graceful-restart restart-time 120

     bgp graceful-restart stalepath-time 360

     bgp graceful-restart

     bgp scan-time 15

     neighbor as65001 peer-group

     neighbor as65001 password cisco

     neighbor as65001 update-source Loopback0

     neighbor as65001 route-reflector-client

     neighbor as65001 next-hop-self

     neighbor 10.255.255.2 remote-as 65001

     neighbor 10.255.255.2 peer-group as65001

     neighbor 10.255.255.3 remote-as 65001

     neighbor 10.255.255.3 peer-group as65001

     neighbor 10.255.255.4 remote-as 65001

     neighbor 10.255.255.4 peer-group as65001

     neighbor 10.255.255.5 remote-as 65001

     neighbor 10.255.255.5 peer-group as65001

     neighbor 10.255.255.6 remote-as 65001

     neighbor 10.255.255.6 peer-group as65001

    !

    R2:

    !

    interface Loopback0

     ip address 10.255.255.2 255.255.255.255

     ip router isis 10

    !

    interface GigabitEthernet1

     ip address 10.10.6.2 255.255.255.252

     ip router isis 10

     negotiation auto

     isis network point-to-point

     isis password cisco

    !

    interface GigabitEthernet2

     ip address 10.10.5.1 255.255.255.252

     ip router isis 10

     negotiation auto

     isis network point-to-point

     isis password cisco

    !

    interface GigabitEthernet3

     ip address 10.10.8.1 255.255.255.252

     ip router isis 10

     negotiation auto

     isis network point-to-point

     isis password cisco

    !

    router isis 10

     net 49.0000.1025.5255.2000.00

     is-type level-2-only

    !

    router bgp 65001

     bgp router-id 10.255.255.2

     bgp cluster-id 10.255.255.1

     bgp log-neighbor-changes

     bgp graceful-restart restart-time 120

     bgp graceful-restart stalepath-time 360

     bgp graceful-restart

     bgp scan-time 15

     neighbor as65001 peer-group

     neighbor as65001 password cisco

     neighbor as65001 update-source Loopback0

     neighbor as65001 route-reflector-client

     neighbor as65001 next-hop-self

     neighbor 10.255.255.1 remote-as 65001

     neighbor 10.255.255.1 peer-group as65001

     neighbor 10.255.255.3 remote-as 65001

     neighbor 10.255.255.3 peer-group as65001

     neighbor 10.255.255.4 remote-as 65001

     neighbor 10.255.255.4 peer-group as65001

     neighbor 10.255.255.5 remote-as 65001

     neighbor 10.255.255.5 peer-group as65001

     neighbor 10.255.255.6 remote-as 65001

     neighbor 10.255.255.6 peer-group as65001

    !

    R3:

    !

    interface Loopback0

     ip address 10.255.255.3 255.255.255.255

     ip router isis 10

    !

    interface GigabitEthernet1

     ip address 10.10.3.1 255.255.255.252

     ip router isis 10

     negotiation auto

     isis network point-to-point

     isis password cisco

    !

    interface GigabitEthernet2

     ip address 10.10.4.2 255.255.255.252

     ip router isis 10

     negotiation auto

     isis network point-to-point

     isis password cisco

    !

    interface GigabitEthernet3

     ip address 10.10.1.1 255.255.255.252

     negotiation auto

     bfd interval 250 min_rx 250 multiplier 3

    !

    router isis 10

     net 49.0000.1025.5255.3000.00

     is-type level-2-only

    !

    router bgp 65001

     bgp router-id 10.255.255.3

     bgp log-neighbor-changes

     bgp graceful-restart restart-time 120

     bgp graceful-restart stalepath-time 360

     bgp graceful-restart

     bgp scan-time 15

     neighbor 10.10.1.2 remote-as 65002

     neighbor 10.10.1.2 password cisco

     neighbor 10.10.1.2 fall-over bfd

     neighbor 10.255.255.1 remote-as 65001

     neighbor 10.255.255.1 password cisco

     neighbor 10.255.255.1 update-source Loopback0

     neighbor 10.255.255.1 next-hop-self

     neighbor 10.255.255.2 remote-as 65001

     neighbor 10.255.255.2 password cisco

     neighbor 10.255.255.2 update-source Loopback0

     neighbor 10.255.255.2 next-hop-self

    !

    R4:

    !

    interface Loopback0

     ip address 10.255.255.4 255.255.255.255

     ip router isis 10

    !

    interface GigabitEthernet1

     ip address 10.10.3.2 255.255.255.252

     ip router isis 10

     negotiation auto

     isis network point-to-point

     isis password cisco

    !

    interface GigabitEthernet2

     ip address 10.10.5.2 255.255.255.252

     ip router isis 10

     negotiation auto

     isis network point-to-point

     isis password cisco

    !

    interface GigabitEthernet3

     ip address 10.10.2.1 255.255.255.252

     negotiation auto

     bfd interval 250 min_rx 250 multiplier 3

    !

    router isis 10

     net 49.0000.1025.5255.4000.00

     is-type level-2-only

    !

    router bgp 65001

     bgp router-id 10.255.255.4

     bgp log-neighbor-changes

     bgp graceful-restart restart-time 120

     bgp graceful-restart stalepath-time 360

     bgp scan-time 15

     neighbor 10.10.2.2 remote-as 65002

     neighbor 10.10.2.2 password cisco

     neighbor 10.10.2.2 fall-over bfd

     neighbor 10.255.255.1 remote-as 65001

     neighbor 10.255.255.1 password cisco

     neighbor 10.255.255.1 update-source Loopback0

     neighbor 10.255.255.1 next-hop-self

     neighbor 10.255.255.2 remote-as 65001

     neighbor 10.255.255.2 password cisco

     neighbor 10.255.255.2 update-source Loopback0

     neighbor 10.255.255.2 next-hop-self

    !

    R5:

    !

    interface Loopback0

     ip address 10.255.255.5 255.255.255.255

     ip router isis 10

    !

    interface GigabitEthernet1

     ip address 10.10.9.1 255.255.255.252

     ip router isis 10

     negotiation auto

     isis network point-to-point

     isis password cisco

    !

    interface GigabitEthernet3

     ip address 10.10.7.2 255.255.255.252

     ip router isis 10

     negotiation auto

     isis network point-to-point

     isis password cisco

    !

    router isis 10

     net 49.0000.1025.5255.5000.00

     is-type level-2-only

    !

    router bgp 65001

     bgp router-id 10.255.255.5

     bgp log-neighbor-changes

     bgp graceful-restart restart-time 120

     bgp graceful-restart stalepath-time 360

     bgp scan-time 15

     network 10.255.255.5 mask 255.255.255.255

     neighbor 10.255.255.1 remote-as 65001

     neighbor 10.255.255.1 password cisco

     neighbor 10.255.255.1 update-source Loopback0

     neighbor 10.255.255.1 next-hop-self

     neighbor 10.255.255.2 remote-as 65001

     neighbor 10.255.255.2 password cisco

     neighbor 10.255.255.2 update-source Loopback0

     neighbor 10.255.255.2 next-hop-self

    !

    R6:

    interface Loopback0

     ip address 10.255.255.6 255.255.255.255

     ip router isis 10

    !

    interface GigabitEthernet1

     ip address 10.10.9.2 255.255.255.252

     ip router isis 10

     negotiation auto

     isis network point-to-point

     isis password cisco

    !

    interface GigabitEthernet3

     ip address 10.10.8.2 255.255.255.252

     ip router isis 10

     negotiation auto

     isis network point-to-point

     isis password cisco

    !

    router isis 10

     net 49.0000.1025.5255.6000.00

     is-type level-2-only

    !

    router bgp 65001

     bgp router-id 10.255.255.6

     bgp log-neighbor-changes

     bgp graceful-restart restart-time 120

     bgp graceful-restart stalepath-time 360

     bgp scan-time 15

     network 10.255.255.6 mask 255.255.255.255

     neighbor 10.255.255.1 remote-as 65001

     neighbor 10.255.255.1 password cisco

     neighbor 10.255.255.1 update-source Loopback0

     neighbor 10.255.255.1 next-hop-self

     neighbor 10.255.255.2 remote-as 65001

     neighbor 10.255.255.2 password cisco

     neighbor 10.255.255.2 update-source Loopback0

     neighbor 10.255.255.2 next-hop-self

    !

    R7:

    interface Loopback0

     ip address 10.255.255.7 255.255.255.255

    !

    interface GigabitEthernet1

     ip address 10.10.1.2 255.255.255.252

     negotiation auto

     bfd interval 250 min_rx 250 multiplier 3

    !

    interface GigabitEthernet2

     ip address 10.10.2.2 255.255.255.252

     negotiation auto

     bfd interval 250 min_rx 250 multiplier 3

    !

    router bgp 65002

     bgp router-id 10.255.255.7

     bgp log-neighbor-changes

     bgp graceful-restart restart-time 120

     bgp graceful-restart stalepath-time 360

     bgp graceful-restart

     bgp scan-time 15

     network 10.255.255.7 mask 255.255.255.255

     neighbor 10.10.1.1 remote-as 65001

     neighbor 10.10.1.1 password cisco

     neighbor 10.10.1.1 fall-over bfd

     neighbor 10.10.2.1 remote-as 65001

     neighbor 10.10.2.1 password cisco

     neighbor 10.10.2.1 fall-over bfd

    !

    在RR1上查看BGP邻居建立情况,如下图:

    在RR2上查看BGP邻居建立情况,如下图:

    规划设计要点:

    1. 网络中两台独立的路由器做RR,并且属于一个cluster
    2. 两台rr不承担流量转发的工作
  • 相关阅读:
    android第四天晚:绘图和handle
    第二天学英语:django 第二章 get started(1)
    C#进程间的同步,实现只能运行一个程序的效果
    C# Winform Chart的配置
    C#平台调用的步骤
    分享一个开源小工具,关于单词的
    C#的log4net、log2console、rollingfile综合配置
    C#,字符串加密
    使用C#尽可能以最少的代码完成多层次的软件配置(基于PropertyGrid控件)
    C# Winform 单例的Form窗体
  • 原文地址:https://www.cnblogs.com/networking/p/9565225.html
Copyright © 2011-2022 走看看