zoukankan      html  css  js  c++  java
  • hdu_1004 Let the Balloon Rise

    Let the Balloon Rise

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 62694    Accepted Submission(s): 23113

    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
    This year, they decide to leave this lovely job to you.
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
    A test case with N = 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     
    Sample Input
    5 green red blue red red 3 pink orange pink 0
     
    Sample Output
    red pink
     
    Author
    WU, Jiazhi
     
    贴上代码
    #include <iostream>
    #include <cstring>
    #include <algorithm>
    #include <string>
    using namespace std;
    
    const int maxn = 1001;
    struct Node {
        int times;
        string str;
    }color[maxn];
    string s;
    int main (){
        int n , i , j , k , max , p , ok ;
        while  ( cin>>n )
        {
            if ( n==0 )
                break;
            k=0;
            for ( int q=0;q<n; q++ )
                color[q].times=0;
            for (  i=0 ; i<n ; i++ )
            {
                ok=1;
                cin>>s;
                for ( j=0; j<k; j++ )
                    if ( s==color[j].str )
                    {
                        ok=0;
                        color[j].times++;
                        break;
                    }
                if (ok)
                {
                    color[k].str = s;
                    color[k].times++;
                    k++;
                }
            }
            max = 0;
            for ( int m=0; m<k; m++ ){
                if ( color[m].times > max )
                {
                    max = color[m].times;
                    p=m;
                }
            }
            cout<<color[p].str<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Block的强强引用问题(循环引用)
    自己封装的下载方法
    MJRefresh上拉刷新下拉加载
    JavaScript 模块的循环加载
    webpack使用require注意事项
    console.log高级用法
    path.resolve()和path.join()的区别
    深入理解react
    react children技巧总结
    揭秘css
  • 原文地址:https://www.cnblogs.com/neverchanje/p/3474257.html
Copyright © 2011-2022 走看看