zoukankan      html  css  js  c++  java
  • Nasty Hacks

    Nasty Hacks

    Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 483 Accepted Submission(s): 345
    Problem Description
    You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use
    to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.
     
    Input
    The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -106 ≤ r, e ≤ 106 and 0 ≤ c ≤ 106.
     
    Output
    Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.
     
    Sample Input
    3
    0 100 70
    100 130 30
    -100 -70 40
     
    Sample Output
    advertise
    does not matter
    do not advertise
    #include <iostream>
    
    using namespace std;
    
    int main()
    {
        int num;
        long long int r,e,c;
        cin>>num;
        for(int i = 0 ; i < num ; i++)
        {
            cin>>r>>e>>c;
            if((e-c)>r)
            cout<<"advertise"<<endl;
            else if((e-c)<r)
            cout<<"do not advertise"<<endl;
            else cout <<"does not matter"<<endl;
        }
        return 0;
    }
  • 相关阅读:
    java获取Mp3播放时长
    angular ajax的使用及controller与service分层
    mysql数据库不能远程访问的问题
    linux安装ant
    jquery中,使用append增加元素时,该元素的绑定监听事件失效
    类变量与实例变量
    ajax两张传输数据方式
    jquery的.html(),.text()和.val()方法
    如何在sublime text上快速访问html页面?
    java学习笔记之线程2wait和notifyAll
  • 原文地址:https://www.cnblogs.com/newpanderking/p/2114930.html
Copyright © 2011-2022 走看看