zoukankan      html  css  js  c++  java
  • HDU Hat's Fibonacci

    Hat's Fibonacci

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 268 Accepted Submission(s): 112
    Problem Description
    A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
    F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
    Your task is to take a number as input, and print that Fibonacci number.
     
    Input
    Each line will contain an integers. Process to end of file.
     
    Output
    For each case, output the result in a line.
     
    Sample Input
    100
     
    Sample Output
    4203968145672990846840663646
    
    
    Note:
    No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
     
    用二维数组模拟大数加法,每一行表述一个数,每一行的一个元素可以代表n位数,这个可以根据自己的需要自己定义。
    其他的就和正常的加法一样了,注意进位处理。
     
    #include <iostream>
    #include <stdio.h>
    using namespace
    std;
    int
    s[7500][670];
    void
    solve(){

        s[1][1] = 1;s[2][1] = 1;
        s[3][1] = 1;s[4][1] = 1;
        int
    i,j,k=0;
        for
    (i = 5;i<7500;i++)
        for
    ( j = 1;j<=670 ;j++)
        {

            k += s[i-1][j]+s[i-2][j]+s[i-3][j]+s[i-4][j];
            s[i][j] = k%10000;
            k = k/10000;
        }

        while
    (k)
        {

            s[i][j++] = k%10000;
            k = k/10000;
        }
    }

    int
    main()
    {

        int
    n,i,j;

        solve();
        while
    (cin>>n)
        {

            for
    (i = 670; i>=1;i--)
            if
    (s[n][i]!=0)break;

            printf("%d",s[n][i]);
            for
    (j = i-1;j>=1;j--)

            printf("%04d",s[n][j]);
            printf("\n");
        }
    }
  • 相关阅读:
    自定义 ClassLoader
    HashCode 解析
    Unsafe与CAS
    ReentrantLock实现原理深入探究
    javaNIO:选择器--实践 Selector
    javaNIO:选择器--理论 Selector
    javaNIO:Socket通道
    CentOs 7 kong 2.3.X oss 自定义插件
    CentOs 7 kong 2.3.X oss 部署安装
    CentOS7 yum安装、配置PostgreSQL 9.6
  • 原文地址:https://www.cnblogs.com/newpanderking/p/2122528.html
Copyright © 2011-2022 走看看