zoukankan      html  css  js  c++  java
  • HDU Common Subsequence

    Common Subsequence

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 182 Accepted Submission(s): 109
    Problem Description
    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
    The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
     
    Sample Input
    abcfbc abfcab
    programming contest 
    abcd mnp
     
    Sample Output
    4
    2
    0

    #include <iostream>
    using namespace
    std;
    int
    main()
    {

        string a,b;
        int
    i,j;
        int
    c[500][500],al,bl;
        while
    (cin>>a>>b)
        {

            al = a.length();
            bl = b.length();
            for
    (i = 0; i < al ; i++)

            c[i][0] = 0;
            for
    (i = 0; i < bl ; i++)

            c[0][i] = 0;
            for
    (i = 0;i < al; i++)
            for
    (j = 0;j < bl; j++)
            {

                if
    (a[i]==b[j])c[i+1][j+1] = c[i][j]+1;
                else

                {

                   c[i+1][j+1] = (c[i][j+1]>=c[i+1][j]?c[i][j+1]:c[i+1][j]);
                }
            }

            cout<<c[i][j]<<endl;
        }
    }
  • 相关阅读:
    从客户端中检测到有潜在危险的 Request.Form 值
    SqlBulkCopy(批量复制)使用方法 && SqlDataAdapter Update
    SQL Server 2014 清理日志
    GitHub for Windows 2.0使用教程
    C#.Net使用正则表达式抓取百度百家文章列表
    c#设计模式-单例模式【转】
    抽象类(abstract)【转】
    C# 与Java初始化顺序及异同(转)
    [转]VisualSVN错误 Cannot query proxy blanket解决办法
    [转]TortoiseSVN客户端重新设置用户名和密码
  • 原文地址:https://www.cnblogs.com/newpanderking/p/2125827.html
Copyright © 2011-2022 走看看