zoukankan      html  css  js  c++  java
  • POJ 1308 Is It A Tree?

    Description

    A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

    There is exactly one node, called the root, to which no directed edges point. 
    Every node except the root has exactly one edge pointing to it. 
    There is a unique sequence of directed edges from the root to each node. 
    For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

    In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

    Input

    The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

    Output

    For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

    Sample Input

    6 8  5 3  5 2  6 4
    5 6  0 0
    
    8 1  7 3  6 2  8 9  7 5
    7 4  7 8  7 6  0 0
    
    3 8  6 8  6 4
    5 3  5 6  5 2  0 0
    -1 -1

    Sample Output

    Case 1 is a tree.
    Case 2 is a tree.
    Case 3 is not a tree.



    简单的并查集。。。。。
    #include <iostream> 
    using namespace std;
    
    int f[100001],num=0; 
    
    int Find(int x){
        if(x==f[x]) return x;
        int fx=f[x];
        f[x]=Find(fx);
        return f[x]; 
        } 
    
    int main()
    {
        int x,y; 
        cin>>x>>y; 
        while(x!=-1&&y!=-1)
        {
         num++; 
         for(int i=1;i<=100000;++i)
         f[i]=i; 
         bool p=0; 
         while(x!=0||y!=0)
         {
          int fx=Find(x),fy=Find(y);
          if(fx==fy) p=1;
          f[fy]=fx; 
          cin>>x>>y;       
                          }
         int i,j; 
         for(i=1;i<=100000;++i)
         f[i]=Find(i); 
         for(i=1;i<=100000;++i)
         if(f[i]!=i)  break;
         j=i; 
         for(i;i<=100000;++i)
         if(f[i]!=f[j]&&f[i]!=i)
         p=1;  
         if(p==1) cout<<"Case "<<num<<" is not a tree."<<endl; 
         else cout<<"Case "<<num<<" is a tree."<<endl;    
         cin>>x>>y;                   
                                         } //system("pause"); 
        return 0; 
        
        } 
  • 相关阅读:
    C++对象模型
    GUID 转 char *
    MFC中App,Doc,MainFrame,View各指针的互相获取
    MFC中设置某个VIEW为当前视图
    MFC中如何在CMainFrame类中访问CxxxView视图类中的成员
    GetMessage 和 PeekMessage 区别
    STL 常用容器
    收发ICMP封包,实现ping
    软件弹窗广告
    python 输入一个字符串,打印出它所有的组合
  • 原文地址:https://www.cnblogs.com/noip/p/2552376.html
Copyright © 2011-2022 走看看