zoukankan      html  css  js  c++  java
  • POJ 1308 Is It A Tree?

    Description

    A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

    There is exactly one node, called the root, to which no directed edges point. 
    Every node except the root has exactly one edge pointing to it. 
    There is a unique sequence of directed edges from the root to each node. 
    For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

    In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

    Input

    The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

    Output

    For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

    Sample Input

    6 8  5 3  5 2  6 4
    5 6  0 0
    
    8 1  7 3  6 2  8 9  7 5
    7 4  7 8  7 6  0 0
    
    3 8  6 8  6 4
    5 3  5 6  5 2  0 0
    -1 -1

    Sample Output

    Case 1 is a tree.
    Case 2 is a tree.
    Case 3 is not a tree.



    简单的并查集。。。。。
    #include <iostream> 
    using namespace std;
    
    int f[100001],num=0; 
    
    int Find(int x){
        if(x==f[x]) return x;
        int fx=f[x];
        f[x]=Find(fx);
        return f[x]; 
        } 
    
    int main()
    {
        int x,y; 
        cin>>x>>y; 
        while(x!=-1&&y!=-1)
        {
         num++; 
         for(int i=1;i<=100000;++i)
         f[i]=i; 
         bool p=0; 
         while(x!=0||y!=0)
         {
          int fx=Find(x),fy=Find(y);
          if(fx==fy) p=1;
          f[fy]=fx; 
          cin>>x>>y;       
                          }
         int i,j; 
         for(i=1;i<=100000;++i)
         f[i]=Find(i); 
         for(i=1;i<=100000;++i)
         if(f[i]!=i)  break;
         j=i; 
         for(i;i<=100000;++i)
         if(f[i]!=f[j]&&f[i]!=i)
         p=1;  
         if(p==1) cout<<"Case "<<num<<" is not a tree."<<endl; 
         else cout<<"Case "<<num<<" is a tree."<<endl;    
         cin>>x>>y;                   
                                         } //system("pause"); 
        return 0; 
        
        } 
  • 相关阅读:
    新版淘淘商城_01_简介
    JavaMail之-通过邮件激活账号
    javaMail发送邮件
    JavaMail学习之一-邮件传输协议
    解决ios的safari不能自动播放audio问题(以及部分微信也不能自动播放)
    css3背景渐变色
    jq杂记
    各种“分享按钮“方法总结
    底部导航统一高度
    js 与或运算符 || && 妙用
  • 原文地址:https://www.cnblogs.com/noip/p/2552376.html
Copyright © 2011-2022 走看看