zoukankan      html  css  js  c++  java
  • POJ 1611 The Suspects

    描述Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
    Once a member in a group is a suspect, all members in the group are suspects.
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.输入The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.输出For each case, output the number of suspects in one line.样例输入

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    样例输出

    4
    1
    1



    水呀。
    #include<iostream>
    //#include<fstream> 
    #include<string.h> 
    using namespace std;
    //ifstream cin("cin.in");
    //ofstream cout("cout.out"); 
    
    int n,m,f[30001],ans=0; 
    
    int Find(int x){
        if(x==f[x]) return x;
        int fx=f[x];
        f[x]=Find(fx);
        return f[x]; 
        } 
    
    void Union(int x,int y){
         int fx=Find(x),fy=Find(y);
         f[fx]=fy;
         return ; 
         } 
    
    int main()
    {
        cin>>n>>m; 
        while(n!=0||m!=0)
        {
         ans=0; 
         for(int i=0;i<n;++i)
         f[i]=i;
    
         for(int i=1;i<=m;++i)
         {
          int k;int x,y; 
          cin>>k;if(k==0) continue; 
          cin>>x;
          for(int j=2;j<=k;++j)
          {
           cin>>y;  
           Union(x,y);     
                  }
                 } 
         
         int x=Find(0);
         for(int i=0;i<n;++i)
         if(Find(i)==x) ans++;
         
         cout<<ans<<endl;      
         cin>>n>>m;          
                         } 
        return 0; 
        }  
  • 相关阅读:
    Mybatis深入浅出之工作原理
    Mybatis深入浅出之缓存机制
    Error :Unable to access jarfile *.jar
    Mysql与JDBC版本兼容性问题
    找工作的正确方法
    关于制作云主机基准镜像
    笔记分享
    Android4.0.1找不到R.java
    android 反编译出错 can not merge I and Z
    [论文理解] Improving the imporved training of Wasserstesin GANS: A consistency term and its dual effect
  • 原文地址:https://www.cnblogs.com/noip/p/2552377.html
Copyright © 2011-2022 走看看