zoukankan      html  css  js  c++  java
  • HDU 1863 畅通工程 (最小生成树)

    省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。 

    Input测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N 
    行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。 
    Output对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。 
    Sample Input

    3 3
    1 2 1
    1 3 2
    2 3 4
    1 3
    2 3 2
    0 100

    Sample Output

    3
    ?
    题解:
      很水的一道最小生成树的题,需要用到并查集,最后判断是否成了一颗最小生成树。
    #include<iostream>
    #include<algorithm>
    using namespace std;
    const int maxn=105;
    int par[maxn];
    int n,m,res,cnt;
    struct edge
    {
        int u,v,cost;
    }es[maxn];
    bool cmp(const edge& a,const edge& b)
    {
        return a.cost<b.cost;
    }
    void init(int n)
    {
        for(int i=1;i<=n;i++)
            par[i]=i;
    }
    int find(int x)
    {
        return x==par[x]?x:par[x]=find(par[x]);
    }
    bool same(int x,int y)
    {
        return find(x)==find(y);
    }
    void unite(int x,int y)
    {
        x=find(x);
        y=find(y);
        if(x!=y)
            par[x]=y;
    }
    bool kruskal()
    {
        sort(es,es+n,cmp);
        init(m);
        res=cnt=0;
        for(int i=0;i<n;i++)
        {
            edge e=es[i];
            if(!same(e.u,e.v))
            {
                cnt++;
                unite(e.u,e.v);
                res+=e.cost;
            }
        }
        if(cnt==m-1)
            return true;
        return false;
    }
    int main()
    {
        while(cin>>n>>m,n)
        {
    
            for(int i=0;i<n;i++)
                cin>>es[i].u>>es[i].v>>es[i].cost;
            if(kruskal())
                cout<<res<<endl;
            else
                cout<<"?"<<endl;
        }
        return 0;
    }



  • 相关阅读:
    Web 跨域请求(OCRS) 前端解决方案
    接口与抽象
    观察者模式
    建造者模式(Builder)
    外观设计模式 (Facade)
    模板方法模式( TemplateMethod)
    原型模式(ProtoType)
    简单工厂法( Factory Method)
    backup与recover
    Oracle自动备份脚本的实现
  • 原文地址:https://www.cnblogs.com/orion7/p/7364997.html
Copyright © 2011-2022 走看看